summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-08-25 10:28:07 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-08-25 10:29:58 +0300
commit7270edfadcd70ce8f18f4cdc1b865a35c06559ae (patch)
tree1456235a7b82954af62daf78b35524bcd90a34c4 /dev-python/pockets
parentdev-python/pockets: add github upstream metadata (diff)
downloadgentoo-7270edfadcd70ce8f18f4cdc1b865a35c06559ae.tar.gz
gentoo-7270edfadcd70ce8f18f4cdc1b865a35c06559ae.tar.bz2
gentoo-7270edfadcd70ce8f18f4cdc1b865a35c06559ae.zip
dev-python/pockets: enable py3.10, enable tests
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pockets')
-rw-r--r--dev-python/pockets/Manifest1
-rw-r--r--dev-python/pockets/pockets-0.9.1-r2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pockets/Manifest b/dev-python/pockets/Manifest
index f94e6731c7fb..c7365505cc16 100644
--- a/dev-python/pockets/Manifest
+++ b/dev-python/pockets/Manifest
@@ -1 +1,2 @@
+DIST pockets-0.9.1.gh.tar.gz 42077 BLAKE2B 0cdc5a63389b7c01df9a2e63fc1e18edfb8471da8084832b3381141459932146fd46e2e1cf8f87fbf33fea8204a46596566be62ca6c5780985f0d7bd18d5d3e3 SHA512 a24418759bc133a0c62cf0a606a851d00cf1bd280c731065b92fb96a5274a45bc2266a4e1fec3db929aacec5baab774667052e7b732a53c4c4a217663c02ec7b
DIST pockets-0.9.1.tar.gz 24993 BLAKE2B 9962655f755bb96853f1b4450f2bdcbd111ba945dc3a5cdaad84bb43a84150e7384ecb3c5758274b9cf578adc1c8991c163c56f72a00a00bf8fed634397e02af SHA512 436f2fd8cfb9c5612733b1163d381f52c28b8749de28f5e0de609d012ccfc10ad77a31851d3e1010feef5b517f287f1e5c7fc4b447e7b080e5536fdaf8d2e9d6
diff --git a/dev-python/pockets/pockets-0.9.1-r2.ebuild b/dev-python/pockets/pockets-0.9.1-r2.ebuild
new file mode 100644
index 000000000000..9524e493f30d
--- /dev/null
+++ b/dev-python/pockets/pockets-0.9.1-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+# No tags upstream, https://github.com/RobRuana/pockets/issues/5
+COMMIT="777724c8eabaf76f6d0c5e4837c982d110509b2e"
+
+DESCRIPTION="Collection of helpful Python tools"
+HOMEPAGE="https://pypi.org/project/pockets/"
+SRC_URI="
+ https://github.com/RobRuana/pockets/archive/${COMMIT}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+BDEPEND="test? ( dev-python/pytz[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's/description-file/description_file/g' "${S}/setup.cfg" ||die
+ default
+}