summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-01 10:00:38 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-01 10:09:43 +0200
commitf6d2cbd85a9ce56c19c20c98ae205b0c5ab2b30b (patch)
tree6074d874765037ff4d8f352a25e88af174e0e552 /dev-python/pgspecial
parentdev-python/anyio: Remove old (diff)
downloadgentoo-f6d2cbd85a9ce56c19c20c98ae205b0c5ab2b30b.tar.gz
gentoo-f6d2cbd85a9ce56c19c20c98ae205b0c5ab2b30b.tar.bz2
gentoo-f6d2cbd85a9ce56c19c20c98ae205b0c5ab2b30b.zip
dev-python/pgspecial: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pgspecial')
-rw-r--r--dev-python/pgspecial/Manifest1
-rw-r--r--dev-python/pgspecial/pgspecial-2.1.1.ebuild59
2 files changed, 0 insertions, 60 deletions
diff --git a/dev-python/pgspecial/Manifest b/dev-python/pgspecial/Manifest
index e19ef31ac83d..0831f7595432 100644
--- a/dev-python/pgspecial/Manifest
+++ b/dev-python/pgspecial/Manifest
@@ -1,2 +1 @@
-DIST pgspecial-2.1.1.tar.gz 51017 BLAKE2B 170db33ca1629244b2c8c2d23a5768528e474660dcaf73079c516d33624202cc05487a338b21ac5bab28780d127923bf24d86231e85cade2f82714add5bdd789 SHA512 4ab8596536b90837c2ed0a11b6bbfecd6e5dc487b073a58a1406e8e70028ebb7010430784963fe27a08a5cc48292785f6d02affb750f4a1b74cbe33a0e06a5f0
DIST pgspecial-2.1.2.tar.gz 51057 BLAKE2B d164555363e421f716fd9a03653fa8ef6628fc15b71a03acb040c321a20d03e4193725ca3a809b3d4b8710e62005ba9637f35789795d7b4e195f653527617436 SHA512 3ef15c96b8ae84c2c346f44607360aad4bd0abe6f2dfec421af1ca176178b19c64d55baece118600038e105cacb4b5f9b9c3eebbd1e816a9e7a78877d2cb604c
diff --git a/dev-python/pgspecial/pgspecial-2.1.1.ebuild b/dev-python/pgspecial/pgspecial-2.1.1.ebuild
deleted file mode 100644
index f835abccdbc1..000000000000
--- a/dev-python/pgspecial/pgspecial-2.1.1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Python implementation of PostgreSQL meta commands"
-HOMEPAGE="
- https://github.com/dbcli/pgspecial/
- https://pypi.org/project/pgspecial/
-"
-
-LICENSE="BSD MIT"
-SLOT="0"
-KEYWORDS="amd64 arm64 x86"
-
-RDEPEND="
- >=dev-python/click-4.1[${PYTHON_USEDEP}]
- >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
- >=dev-python/psycopg-3.0.10:0[${PYTHON_USEDEP}]
- >=dev-python/sqlparse-0.1.19[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- >=dev-db/postgresql-8.1[server]
- )
-"
-
-distutils_enable_tests pytest
-
-DOCS=( License.txt README.rst changelog.rst )
-
-EPYTEST_DESELECT=(
- # assumes a very specific locale
- tests/test_specials.py::test_slash_l
- tests/test_specials.py::test_slash_l_pattern
- # change in postgres? *shrug*
- tests/test_specials.py::test_slash_d_view_verbose
-)
-
-src_test() {
- local db=${T}/pgsql
-
- initdb --username=postgres -D "${db}" || die
- # TODO: random port
- pg_ctl -w -D "${db}" start \
- -o "-h '127.0.0.1' -p 5432 -k '${T}'" || die
- psql -h "${T}" -U postgres -d postgres \
- -c "ALTER ROLE postgres WITH PASSWORD 'postgres';" || die
- createdb -h "${T}" -U postgres _test_db || die
-
- distutils-r1_src_test
-
- pg_ctl -w -D "${db}" stop || die
-}