summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-08-31 23:38:41 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-08-31 23:38:41 +0200
commitacb22c6436b4bebcea7a948aa336e755efde584f (patch)
tree820006e568d2082845560853188a78a7f1cc6daa /dev-python/pathlib2/pathlib2-2.3.2.ebuild
parentdev-libs/openssl: fix USE=bindist (diff)
downloadgentoo-acb22c6436b4bebcea7a948aa336e755efde584f.tar.gz
gentoo-acb22c6436b4bebcea7a948aa336e755efde584f.tar.bz2
gentoo-acb22c6436b4bebcea7a948aa336e755efde584f.zip
dev-python/pathlib2: bump to 2.3.2, add PyPy3, Python 3.7
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'dev-python/pathlib2/pathlib2-2.3.2.ebuild')
-rw-r--r--dev-python/pathlib2/pathlib2-2.3.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pathlib2/pathlib2-2.3.2.ebuild b/dev-python/pathlib2/pathlib2-2.3.2.ebuild
new file mode 100644
index 000000000000..3fe4dfe28789
--- /dev/null
+++ b/dev-python/pathlib2/pathlib2-2.3.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fork of pathlib aiming to support the full stdlib Python API"
+HOMEPAGE="https://github.com/mcmtroffaes/pathlib2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ $(python_gen_cond_dep 'dev-python/scandir[${PYTHON_USEDEP}]' -2 python3_4 )
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2)
+ )
+"
+
+python_test() {
+ "${EPYTHON}" tests/test_pathlib2.py -v || \
+ die "tests failed with ${EPYTHON}"
+}