summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-04 16:46:38 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-04 20:08:07 +0200
commit0408d520a070cf35c6791874ef24bb1ac63f9b4f (patch)
treee51898c56b32f3dc7ae4e7c10cfdbc63842a6b56 /dev-python/path
parentdev-python/path: Bump to 16.10.2 (diff)
downloadgentoo-0408d520a070cf35c6791874ef24bb1ac63f9b4f.tar.gz
gentoo-0408d520a070cf35c6791874ef24bb1ac63f9b4f.tar.bz2
gentoo-0408d520a070cf35c6791874ef24bb1ac63f9b4f.zip
dev-python/path: Bump to 16.12.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/path')
-rw-r--r--dev-python/path/Manifest1
-rw-r--r--dev-python/path/path-16.12.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/path/Manifest b/dev-python/path/Manifest
index 50ed89409e63..965d42d959b2 100644
--- a/dev-python/path/Manifest
+++ b/dev-python/path/Manifest
@@ -1,2 +1,3 @@
DIST path-16.10.0.tar.gz 49271 BLAKE2B 36762e0b50d74b07db14ca01c6d94577f24b36c007eda58de4b63197cd91f869efbdc5ac1ceb270f1fc5e5a07c4c87f6cabd10cbac5fac74681f73451a3f73e1 SHA512 a5dfa964f5ffd4c2aa27733716b67437f02fd6dedc8c574bb87a9a3ac64eb60d27c3a05217aa4859293ebd96bdd17cdb1a04ea21c6ad35b7b22f05725826c057
DIST path-16.10.2.tar.gz 49415 BLAKE2B 3784b557bc31b17523a0fe37ebc646f932edd2427c6cae6d3544db29a689026b1e828d0d105234af10787f494ff1afce95e7935a36f01477a9434ce8994113d9 SHA512 df698a44b7c3f0b0dac1f5a3668c3a76f0b473921696bba2e4a66d4b7c7379bcda5938a9800a628dbaa487b6a35920266edee13ea829ee0f4cabb3ec1c30dca1
+DIST path-16.12.1.tar.gz 49685 BLAKE2B 2e2fca5db8ed82764686f4cb9a3de0ce18ce92e6e70999ffd93f13638a061cb2b3624d96f91740cba3efc9fcb8d80c37b55ab9595138e90764093901ab05c111 SHA512 144710438a0ed6f433094f9c27c0f9a3de02e6ee3fad337092a3b8d3c969746f330d4380924ba2ef17f99dc2757cde47115e392f6ee393bcd9f650e0f214d145
diff --git a/dev-python/path/path-16.12.1.ebuild b/dev-python/path/path-16.12.1.ebuild
new file mode 100644
index 000000000000..5346cd3c6d67
--- /dev/null
+++ b/dev-python/path/path-16.12.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A module wrapper for os.path"
+HOMEPAGE="
+ https://github.com/jaraco/path/
+ https://pypi.org/project/path/
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # unreliable, not really meaningful for end users
+ test_path.py::TestPerformance
+)