summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-30 13:11:33 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-31 01:23:56 +0100
commit7724e813891c1f98dfa6df04bd546ec78c1f9dc5 (patch)
treeeb49ad7939805e2198ab5887975f0987851f6078 /dev-python/pandas
parentdev-python/pillow: Run a single Xvfb (diff)
downloadgentoo-7724e813891c1f98dfa6df04bd546ec78c1f9dc5.tar.gz
gentoo-7724e813891c1f98dfa6df04bd546ec78c1f9dc5.tar.bz2
gentoo-7724e813891c1f98dfa6df04bd546ec78c1f9dc5.zip
dev-python/pandas: Run a single Xvfb
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pandas')
-rw-r--r--dev-python/pandas/pandas-1.4.0.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-python/pandas/pandas-1.4.0.ebuild b/dev-python/pandas/pandas-1.4.0.ebuild
index 922f3eec3723..a29bcb00cd44 100644
--- a/dev-python/pandas/pandas-1.4.0.ebuild
+++ b/dev-python/pandas/pandas-1.4.0.ebuild
@@ -140,6 +140,10 @@ python_compile_all() {
fi
}
+src_test() {
+ virtx distutils-r1_src_test
+}
+
python_test() {
local EPYTEST_DESELECT=(
# test for rounding errors, fails if we have better precision
@@ -155,8 +159,9 @@ python_test() {
local -x LC_ALL=C.UTF-8
cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
"${EPYTHON}" -c "import pandas; pandas.show_versions()" || die
- virtx epytest pandas --skip-slow --skip-network -m "not single" \
- -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+ epytest pandas --skip-slow --skip-network -m "not single" \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" ||
+ die "Tests failed with ${EPYTHON}"
}
python_install_all() {