summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-03-25 17:32:20 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-03-25 17:32:20 -0500
commit7884cf1546a387a52a9bcbaa56b0cfb1efd4f4c1 (patch)
tree176432116a6bcfdcaf4e616e12b2a3eb272d9199 /dev-python/oslo-context/oslo-context-2.2.0.ebuild
parentdev-python/oslo-versionedobjects: bup for mitaka (diff)
downloadgentoo-7884cf1546a387a52a9bcbaa56b0cfb1efd4f4c1.tar.gz
gentoo-7884cf1546a387a52a9bcbaa56b0cfb1efd4f4c1.tar.bz2
gentoo-7884cf1546a387a52a9bcbaa56b0cfb1efd4f4c1.zip
dev-python/oslo-context: bup for mitaka
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/oslo-context/oslo-context-2.2.0.ebuild')
-rw-r--r--dev-python/oslo-context/oslo-context-2.2.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/oslo-context/oslo-context-2.2.0.ebuild b/dev-python/oslo-context/oslo-context-2.2.0.ebuild
new file mode 100644
index 000000000000..ca235592e08b
--- /dev/null
+++ b/dev-python/oslo-context/oslo-context-2.2.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Helpers to maintain useful information about a request context"
+HOMEPAGE="https://pypi.python.org/pypi/oslo.context"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.context/oslo.context-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-sphinx-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3.0[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/oslo.context-${PV}"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+# This time half the doc files are missing; Do you want them?
+python_test() {
+ nosetests tests/ || die "test failed under ${EPYTHON}"
+}