summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-20 05:25:06 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-20 06:45:41 +0200
commit69f24988ef14e24c9e2e286a03699a739d7f92d9 (patch)
tree8fcb47b322be7a935fb744fd52f43c4e2e8e1462 /dev-python/openpyxl
parentapp-admin/awscli: Bump to 1.33.12 (diff)
downloadgentoo-69f24988ef14e24c9e2e286a03699a739d7f92d9.tar.gz
gentoo-69f24988ef14e24c9e2e286a03699a739d7f92d9.tar.bz2
gentoo-69f24988ef14e24c9e2e286a03699a739d7f92d9.zip
dev-python/openpyxl: Fix numpy-2 compatibility (replace deselect)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/openpyxl')
-rw-r--r--dev-python/openpyxl/openpyxl-3.1.4.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/dev-python/openpyxl/openpyxl-3.1.4.ebuild b/dev-python/openpyxl/openpyxl-3.1.4.ebuild
index e1d43c5174d6..fc85d81542c8 100644
--- a/dev-python/openpyxl/openpyxl-3.1.4.ebuild
+++ b/dev-python/openpyxl/openpyxl-3.1.4.ebuild
@@ -35,18 +35,19 @@ distutils_enable_sphinx doc \
dev-python/sphinx-rtd-theme
distutils_enable_tests pytest
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # https://foss.heptapod.net/openpyxl/openpyxl/-/issues/2187
+ sed -i -e 's:float_:float64:' openpyxl/compat/tests/test_compat.py || die
+}
+
python_test() {
local EPYTEST_DESELECT=(
# GC assumptions (pypy)
openpyxl/tests/test_iter.py::test_file_descriptor_leak
)
- if has_version ">=dev-python/numpy-2[${PYTHON_USEDEP}]"; then
- EPYTEST_DESELECT+=(
- # https://foss.heptapod.net/openpyxl/openpyxl/-/issues/2187
- openpyxl/compat/tests/test_compat.py::test_numpy_tostring
- )
- fi
-
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest
}