summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-21 14:48:08 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-21 14:59:10 +0100
commit44f86f9d1aa28c879ba16e3e70a0ae72b9f684ce (patch)
treee2bdeb39c63364c06adddc168507b11f83cd8bf9 /dev-python/ndg-httpsclient
parentdev-python/pyaes: Enable py3.8, pypy3 (diff)
downloadgentoo-44f86f9d1aa28c879ba16e3e70a0ae72b9f684ce.tar.gz
gentoo-44f86f9d1aa28c879ba16e3e70a0ae72b9f684ce.tar.bz2
gentoo-44f86f9d1aa28c879ba16e3e70a0ae72b9f684ce.zip
dev-python/ndg-httpsclient: Bump to 0.5.1
Closes: https://bugs.gentoo.org/709964 Closes: https://bugs.gentoo.org/654612 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ndg-httpsclient')
-rw-r--r--dev-python/ndg-httpsclient/Manifest1
-rw-r--r--dev-python/ndg-httpsclient/ndg-httpsclient-0.5.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/ndg-httpsclient/Manifest b/dev-python/ndg-httpsclient/Manifest
index cdc9f522322e..7f161b48de39 100644
--- a/dev-python/ndg-httpsclient/Manifest
+++ b/dev-python/ndg-httpsclient/Manifest
@@ -1,2 +1,3 @@
DIST ndg_httpsclient-0.4.0.tar.gz 24038 BLAKE2B 147ba36c966b2220c068ce3376bd84259807f66c57141fee4ed95457333cd9d568d19fd4d3348e7ef25d456e3f7d794f83f8302a15beb16f451aa02ef6181848 SHA512 3c0225a20c25cf0f12f03005bb79e738527c0488bb660c1eb3b55c505a0ef503002d37fcffb3d013e5f91101bdd03080a68d5805d6d29b682cc01bdc9f0e4a19
DIST ndg_httpsclient-0.4.2.tar.gz 25062 BLAKE2B 740075cf3031547028afa3ec2e005e5430e7fbb5c2bfd444e4051c60a9ac14ecacd3048f87f546516bddc4c0403738aa3ef227b3fd763a48bca28da09a47f707 SHA512 c7d6f442242ce01f69d2386b8ed41e4e5f72a2523ecbe38785c4333405f1b000e298133ccc4169d9685a3dcdcf0b20567c8e4b2dfd36f42721d36c73ee27d90a
+DIST ndg_httpsclient-0.5.1.tar.gz 26665 BLAKE2B 1c7f0a8d41b945d2b2a51cd69397ab0943cb91e25013c931f055c5608bc3a0106a99d9b126e8caaac9f8d9b409ec117631fb23f19dfd3194b783548ce3536050 SHA512 b2b4c1b1df87ea1a94811b9ae831e7bf32af27258f487fd5ec319e0e6e0d79dfdb1f7bfadaf397d0693a8a7f0720df170a7fc946aaf10c82e3957ac5464f672e
diff --git a/dev-python/ndg-httpsclient/ndg-httpsclient-0.5.1.ebuild b/dev-python/ndg-httpsclient/ndg-httpsclient-0.5.1.ebuild
new file mode 100644
index 000000000000..4ad33ed68364
--- /dev/null
+++ b/dev-python/ndg-httpsclient/ndg-httpsclient-0.5.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides enhanced HTTPS support for httplib and urllib2 using PyOpenSSL"
+HOMEPAGE="
+ https://github.com/cedadev/ndg_httpsclient/
+ https://pypi.org/project/ndg-httpsclient/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P/-/_}.tar.gz"
+S="${WORKDIR}/${P/-/_}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ dev-python/pyaes[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]"
+# we need to block the previous versions since incorrect namespace
+# install breaks tests
+DEPEND="${RDEPEND}
+ test? (
+ !!<dev-python/ndg-httpsclient-0.4.2-r1
+ dev-libs/openssl:0
+ sys-libs/libfaketime
+ )"
+
+distutils_enable_tests unittest
+
+src_test() {
+ # bundled certificates expired, so we need a time machine
+ local -x FAKETIME="@2019-12-01 12:00:00"
+ local -x LD_PRELOAD="libfaketime.so:${LD_PRELOAD}"
+
+ # we need to start a fake https server for tests to connect to
+ ( cd ndg/httpsclient/test && sh ./scripts/openssl_https_server.sh ) &
+ local server_pid=${!}
+
+ distutils-r1_src_test
+
+ kill "${server_pid}"
+ wait
+}