summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-12 12:29:12 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-12 13:18:34 +0200
commite35ede98e25393f8e03665b5c5be642907478022 (patch)
tree7992d8482158cc343afa27da903c3695d8ebd434 /dev-python/nbclassic
parentsys-kernel/vanilla-sources: add 6.0.1, drop 6.0.0 (diff)
downloadgentoo-e35ede98e25393f8e03665b5c5be642907478022.tar.gz
gentoo-e35ede98e25393f8e03665b5c5be642907478022.tar.bz2
gentoo-e35ede98e25393f8e03665b5c5be642907478022.zip
dev-python/nbclassic: Bump to 0.4.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nbclassic')
-rw-r--r--dev-python/nbclassic/Manifest1
-rw-r--r--dev-python/nbclassic/nbclassic-0.4.6.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/nbclassic/Manifest b/dev-python/nbclassic/Manifest
index 8846872f72dd..4963f89eb622 100644
--- a/dev-python/nbclassic/Manifest
+++ b/dev-python/nbclassic/Manifest
@@ -1,3 +1,4 @@
DIST nbclassic-0.3.7.tar.gz 15973 BLAKE2B a26a975fa8711c41a199e0b88b5ec83aefa4b812fce6ab4a765aa4920fae6b863519dbae556d663bf761a866a26ee6fe7c322c947312b89770a34f2a5b570455 SHA512 3ceaeeafa7e56d17cda29e4c86b4cb5f44517721b47e41ad1ac535704b8f460d88a5feb280ad8a9cef78366581e08c94837cab4ef2eae8dbce2ded183a787ea2
DIST nbclassic-0.4.4.tar.gz 19873779 BLAKE2B ebdca5cb80de439f305406b0507f460a600c03a8fbb90b28d962974147d9e94f374282c02653019f2a519078812c2b25bbbcc9c12befbcdac72f305135437a70 SHA512 f7b425ea78f555d2d9d60e221fd3d3f551f7fa4ed4f6178a0596ff59ec0c1ead212f2102aeeaedf95ec3c5f7c2ea7536c21ff5df9f5b78b9718ab9bdf23159bf
DIST nbclassic-0.4.5.tar.gz 19873691 BLAKE2B e7ebc2503bff405c18d1488391a9ab50c170bce9d3cf1b51944d24f4891a483b4c17c3dcb31c9021f8ab2ae5687fd800fd17d80b4872b9e5eeb4d9012081d724 SHA512 690ada48801ab4de94fea35460021c9692c97500e343312d0e229400fad5e404fdb3b0b1e32a8ce3fce1ba213c0ea9dcd3cb4fdf7dc3bde0fa3458397ae4020c
+DIST nbclassic-0.4.6.tar.gz 19870837 BLAKE2B aba744557f6a87fd95669c0736c314714f2318abe65ed5ca0d5c4236245e27bfde52fe486e43a7369587103459598540e15738d002da859413f3f59d87f5358c SHA512 915265679194b8101ef7f11fd6a76cfa2c238d2b533f40bd3dd9f91b12488f9f5738a0f5ba06882a2898e231525a8b160506cb07f0c0837a64af6fdca1295065
diff --git a/dev-python/nbclassic/nbclassic-0.4.6.ebuild b/dev-python/nbclassic/nbclassic-0.4.6.ebuild
new file mode 100644
index 000000000000..b2720d14f833
--- /dev/null
+++ b/dev-python/nbclassic/nbclassic-0.4.6.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=jupyter
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="Jupyter Notebook as a Jupyter Server Extension"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/nbclassic/
+ https://pypi.org/project/nbclassic/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/jupyter_server-1.17.0[${PYTHON_USEDEP}]
+ <dev-python/notebook-7[${PYTHON_USEDEP}]
+ >=dev-python/notebook_shim-0.1.0[${PYTHON_USEDEP}]
+"
+
+# pytest-console-scripts seem unused
+BDEPEND="
+ test? (
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ )
+ doc? (
+ virtual/pandoc
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/source \
+ dev-python/sphinx_rtd_theme \
+ dev-python/nbsphinx \
+ dev-python/sphinxcontrib-github-alt \
+ dev-python/myst_parser \
+ dev-python/ipython_genutils
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_tornasync.plugin
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ # move /usr/etc stuff to /etc
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}