summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-18 05:49:53 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-18 06:18:33 +0100
commit6f3a6c7a5593d81f833ee32313b81c1941770a60 (patch)
treeabf9761943aac6a446530fb2ede7711228611e4a /dev-python/markdown2
parentdev-python/pypdf: Bump to 3.17.3 (diff)
downloadgentoo-6f3a6c7a5593d81f833ee32313b81c1941770a60.tar.gz
gentoo-6f3a6c7a5593d81f833ee32313b81c1941770a60.tar.bz2
gentoo-6f3a6c7a5593d81f833ee32313b81c1941770a60.zip
dev-python/markdown2: Bump to 2.4.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/markdown2')
-rw-r--r--dev-python/markdown2/Manifest1
-rw-r--r--dev-python/markdown2/markdown2-2.4.12.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/markdown2/Manifest b/dev-python/markdown2/Manifest
index a4565fcb5cc5..14a3aa5f9589 100644
--- a/dev-python/markdown2/Manifest
+++ b/dev-python/markdown2/Manifest
@@ -1,2 +1,3 @@
DIST markdown2-2.4.10.tar.gz 123813 BLAKE2B 4aee5ece385a6987fc9d8fccbd3141f42f6469328d0c6ddd7bfeb4bcbffb2cdf2a6375bd9fab8dbc79b099894303e94f15df334b244d877970cc5e52d2f0bf5f SHA512 1053d5e13dfe83158c7e1b87a68f12a2d5bdeddf1cae359c2992028687d18e69d71c1347ac04cbfcbcb4a6c629eeb1f465537e2e4b47c0594f0c5d175b9ce04f
DIST markdown2-2.4.11.tar.gz 128610 BLAKE2B 0418b97589be177bd3ac76d426e653f2ec48b1e12ab54d7a3e1d1e69a0f926e59fb0287f02ba9e72047ac62c0a1bc404711ad7e0e10a4aec32606d2231d32c71 SHA512 dbb7130eaf0924741694e905fc6ca8c2f0c46059c5aec144c3170b6793f2c50d2b0be90bd76f775a79e83101c3b0a549056c5e8f0ea0fed911c22ae1844b0c31
+DIST markdown2-2.4.12.tar.gz 129973 BLAKE2B a4e693a63cbb30a4c5351e3dd5974fa9750ff22ef956a5e09b53056081d2a95072b5c591f3f084913247691ffdef8c96a20bdd56b916a77a0319c663de2fada8 SHA512 db5f75b03e2056b43c4c3fde0e7b0e3d3b584d9ce2d4a71dbaf53d733c33ac20bf497bd3eb64ff3c8b4947969cf581bb50496ba189a39b8edcc9130cacb0874a
diff --git a/dev-python/markdown2/markdown2-2.4.12.ebuild b/dev-python/markdown2/markdown2-2.4.12.ebuild
new file mode 100644
index 000000000000..40066426c08c
--- /dev/null
+++ b/dev-python/markdown2/markdown2-2.4.12.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python Markdown language reimplementation"
+HOMEPAGE="
+ https://github.com/trentm/python-markdown2/
+ https://pypi.org/project/markdown2/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/pygments-2.7.3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ cd test || die
+ "${EPYTHON}" -m unittest test_markdown2.py -v ||
+ die "Tests fail with ${EPYTHON}"
+}