summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-21 06:05:17 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-21 06:55:19 +0200
commite19fde42e2ca1a4f164a98a90e731a566c347457 (patch)
treeb40c270452abf34c1d6513baddd74ba77ecc4e79 /dev-python/llfuse
parentdev-libs/libclc: Add 17.0.0_pre20230520 snapshot (diff)
downloadgentoo-e19fde42e2ca1a4f164a98a90e731a566c347457.tar.gz
gentoo-e19fde42e2ca1a4f164a98a90e731a566c347457.tar.bz2
gentoo-e19fde42e2ca1a4f164a98a90e731a566c347457.zip
dev-python/llfuse: Bump to 1.4.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/llfuse')
-rw-r--r--dev-python/llfuse/Manifest1
-rw-r--r--dev-python/llfuse/llfuse-1.4.4.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/llfuse/Manifest b/dev-python/llfuse/Manifest
index e7cb3898bb28..abeaa5f1046f 100644
--- a/dev-python/llfuse/Manifest
+++ b/dev-python/llfuse/Manifest
@@ -1 +1,2 @@
DIST llfuse-1.4.2.tar.gz 834763 BLAKE2B 60bdfdd4567de4aa6ab5ea6692f48e6d68572bc13976e30fa9850c96b8a2c8a77638d3750df549b827a2bba0cc2dfa2a3f2cac3c4729278515a2703ecde446a1 SHA512 6a368af9e49f8537bbea396dfcd9fc024f8b93b161d3c6167d13c4ffb0ab20b6c8393447e71b5c147c82d4d1ee590ae08c512c93ccb28df78a06ab6833ac3705
+DIST llfuse-1.4.4.tar.gz 293728 BLAKE2B aba684a0b7b06a0cdb97fb8851639ee0c6b5dc100e3d216430e26f122a78ac7933b7d5725f271328804a592b343988d6ceb79bd8c682620464dcef1d26cc20b0 SHA512 3e61f1f82194dc915947e4f0c2edf44ce0e87c4da142e39c2b19bb7db3f387a348f9c1bb02b6d0f2507b57cbfc20ad83c11ce513c685dc276d6a382e4dd449eb
diff --git a/dev-python/llfuse/llfuse-1.4.4.ebuild b/dev-python/llfuse/llfuse-1.4.4.ebuild
new file mode 100644
index 000000000000..9c9206538605
--- /dev/null
+++ b/dev-python/llfuse/llfuse-1.4.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python bindings for the low-level FUSE API"
+HOMEPAGE="
+ https://github.com/python-llfuse/python-llfuse/
+ https://pypi.org/project/llfuse/
+"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="doc examples"
+
+RDEPEND="
+ >=sys-fs/fuse-2.8.0:0
+"
+DEPEND="
+ ${RDEPEND}
+ sys-apps/attr
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/llfuse-1.3.5-cflags.patch
+)
+
+distutils_enable_sphinx rst
+distutils_enable_tests pytest
+
+src_prepare() {
+ # force regen
+ rm src/llfuse.c || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ if [[ ! -f src/llfuse.c ]]; then
+ esetup.py build_cython
+ fi
+ distutils-r1_python_compile
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}