summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-02-01 20:58:55 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-02-01 22:41:47 +0200
commitdeb427c10768078cfbd23a14eb9cb569bf7d5d94 (patch)
tree00ad5c4314eb08385ef824117edc5ee2554db33a /dev-python/libpillowfight
parentsys-libs/glibc: 2.33 patchset bump, again (diff)
downloadgentoo-deb427c10768078cfbd23a14eb9cb569bf7d5d94.tar.gz
gentoo-deb427c10768078cfbd23a14eb9cb569bf7d5d94.tar.bz2
gentoo-deb427c10768078cfbd23a14eb9cb569bf7d5d94.zip
dev-python/libpillowfight: fix test calls
Use better way to handle pytest C errors Fixes: 9b96d2dfc7572357be8dbd92fc9302660c196129 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/libpillowfight')
-rw-r--r--dev-python/libpillowfight/libpillowfight-0.3.0_p20210816.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/dev-python/libpillowfight/libpillowfight-0.3.0_p20210816.ebuild b/dev-python/libpillowfight/libpillowfight-0.3.0_p20210816.ebuild
index 5e1ace91926e..62e40857072e 100644
--- a/dev-python/libpillowfight/libpillowfight-0.3.0_p20210816.ebuild
+++ b/dev-python/libpillowfight/libpillowfight-0.3.0_p20210816.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -23,6 +23,7 @@ RDEPEND="dev-python/pillow[${PYTHON_USEDEP}]"
distutils_enable_tests nose
python_prepare_all() {
+ ln -s "${S}"/tests "${T}"/tests || die
sed -e "/'nose>=1.0'/d" -i setup.py || die
cat > src/pillowfight/_version.h <<- EOF || die
#define INTERNAL_PILLOWFIGHT_VERSION "$(ver_cut 1-3)"
@@ -31,8 +32,6 @@ python_prepare_all() {
}
python_test() {
- cp -r -l -n tests "${BUILD_DIR}/lib" || die
- cd "${BUILD_DIR}/lib" || die
- distutils-r1_python_test
- rm -r tests || die
+ cd "${T}" || die
+ epytest "${S}"/tests -o addopts=
}