summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-24 07:33:25 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-24 09:49:14 +0100
commitd8b86dc0f628911b7f6d04d30bfd148dc381d150 (patch)
treec581da1d57e7515ebe0c02604441fe266a2bb572 /dev-python/leather
parentdev-python/pipdeptree: Bump to 2.15.1 (diff)
downloadgentoo-d8b86dc0f628911b7f6d04d30bfd148dc381d150.tar.gz
gentoo-d8b86dc0f628911b7f6d04d30bfd148dc381d150.tar.bz2
gentoo-d8b86dc0f628911b7f6d04d30bfd148dc381d150.zip
dev-python/leather: Bump to 0.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/leather')
-rw-r--r--dev-python/leather/Manifest1
-rw-r--r--dev-python/leather/leather-0.4.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/leather/Manifest b/dev-python/leather/Manifest
index e5864e33e632..998db848fd52 100644
--- a/dev-python/leather/Manifest
+++ b/dev-python/leather/Manifest
@@ -1 +1,2 @@
DIST leather-0.3.4.gh.tar.gz 41368 BLAKE2B a1181da5904234677290134726da33a71e0f37e6f0161beb0ec7a73efca1b2b26e973221f2f42b72fd2640ef503a8adc905273885deef212ee9d1aae6d91f804 SHA512 0547adf5d455afe9397cf9c597cc7edbcdbe25bb56e32d764c67119bfe1329d959834f2a41720adb51ec926065e044feb27f7a5e3f800c8636a22d4f96752212
+DIST leather-0.4.0.gh.tar.gz 41100 BLAKE2B fdba2a55f631b783095af37ed944c388865d2ffe9e9ddc943ab4ce4bb6718135fa459d21f28f914fa16bbdde96ec4773e689feece6eddda894683572bf8bae2b SHA512 04341b5806484482374514c0efe47550b7b0ea1106bbebaa8b221366b8d4e36ef555e5dcb93227a97191d4fc7ba3483966db74bd51f25c7f08f4d1e9a08f0caf
diff --git a/dev-python/leather/leather-0.4.0.ebuild b/dev-python/leather/leather-0.4.0.ebuild
new file mode 100644
index 000000000000..5d92cba06136
--- /dev/null
+++ b/dev-python/leather/leather-0.4.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python charting for 80% of humans"
+HOMEPAGE="
+ https://github.com/wireservice/leather/
+ https://pypi.org/project/leather/
+"
+SRC_URI="
+ https://github.com/wireservice/leather/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~arm64-macos ~x64-macos"
+
+BDEPEND="
+ test? (
+ >=dev-python/cssselect-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.6.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/furo