summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-07 17:05:14 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-07 17:10:10 +0100
commit1f474e5a9f1ed8f9bbb162ee8a66e9c7289dfc96 (patch)
treeb260f52a65fc6ffdeb752d5b02dd13e30f4ead8a /dev-python/lark
parentdev-python/zconfig: Bump to 3.6.1 (diff)
downloadgentoo-1f474e5a9f1ed8f9bbb162ee8a66e9c7289dfc96.tar.gz
gentoo-1f474e5a9f1ed8f9bbb162ee8a66e9c7289dfc96.tar.bz2
gentoo-1f474e5a9f1ed8f9bbb162ee8a66e9c7289dfc96.zip
dev-python/lark: Bump to 1.1.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/lark')
-rw-r--r--dev-python/lark/Manifest1
-rw-r--r--dev-python/lark/lark-1.1.5.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/lark/Manifest b/dev-python/lark/Manifest
index dfa5cc3138b8..0f5134144235 100644
--- a/dev-python/lark/Manifest
+++ b/dev-python/lark/Manifest
@@ -1,2 +1,3 @@
DIST lark-1.1.3.tar.gz 245913 BLAKE2B 4c7b53d123aa7cdffcb16027921fced2f94dc0e5b9b816825f297629a9ff446758d9a700dc0f243f3d4c478fc992bbf5bfb38c51c2be3c8379df06b41044c624 SHA512 5359a29852554049ecee77a4151a2c64c5af72eccf5c2bb07926b0c131caac15cc51777c2df1d2c736e9e2b45d59543aa8a6d16ef2cb92ea7f8564c7ac06edb2
DIST lark-1.1.4.tar.gz 246520 BLAKE2B 08073f89a3403d5e722b3af4d9226ea4ca890a7ad9978fb69f023f1219bb2d148533a68810188d3af35770cc36d29629a1c57a3fbab4098e9ec3d4e73f68ffe8 SHA512 32498f8c387320dce89ebab66e9eed49dc83b855060a8fb9459e6323d0d783ff7184ac997ff095fead09766c00f28c12ccbcd614effb8344ba49df51f7b5a566
+DIST lark-1.1.5.tar.gz 246737 BLAKE2B 2111bb6c2f6eaa05b803daf11f0f55641c9b3943a97f943fd27b5dd33f8b511e3b0fc4fb335edbb3926ad19da6cb2696b7f87003b7def068cae1d805b3feb8d9 SHA512 8103e050745c83c99b077667aa8b1d4dfad28f5554d2381534b3518d8d3e8adb70f0304fdc7e1c762d3ea26089181d9632dea155b6cd97237078b89330a6711e
diff --git a/dev-python/lark/lark-1.1.5.ebuild b/dev-python/lark/lark-1.1.5.ebuild
new file mode 100644
index 000000000000..48eebe3a0446
--- /dev/null
+++ b/dev-python/lark/lark-1.1.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module to propose a modern general-purpose parsing library for Python"
+HOMEPAGE="
+ https://github.com/lark-parser/lark/
+ https://pypi.org/project/lark/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/lark/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/atomicwrites[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # require dev-python/js2py which is a really bad quality package
+ tests/test_nearley/test_nearley.py
+ )
+
+ if has "${EPYTHON}" pypy3 python3.{8,9}; then
+ EPYTEST_IGNORE+=(
+ # test using Python 3.10+ syntax
+ tests/test_pattern_matching.py
+ )
+ fi
+
+ epytest
+}