summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/larch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/larch')
-rw-r--r--dev-python/larch/Manifest2
-rw-r--r--dev-python/larch/larch-1.20130808.ebuild36
-rw-r--r--dev-python/larch/larch-1.20131130.ebuild36
-rw-r--r--dev-python/larch/metadata.xml8
4 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/larch/Manifest b/dev-python/larch/Manifest
new file mode 100644
index 000000000000..72734e08b213
--- /dev/null
+++ b/dev-python/larch/Manifest
@@ -0,0 +1,2 @@
+DIST python-larch_1.20130808.orig.tar.gz 88271 SHA256 f64599ebd5247bc79ed69cdc853ae08cc3d0d8648fa7737ad2854854cc843045 SHA512 84bab884e3ff8e27cc43e2520eb10fb7a38d99eddb06b9163e174329d69552e678ef81d606fa041f894794f0ba3bdf59ace3081f71596869e1167a0e23d56c85 WHIRLPOOL ff86df6db0d0dac024ba086e2264028abd74b45f73cae773c5c8a7b91ad9df54ab8f092fa85b277f27f7d17b50391037059624c533e04ef97108751d7c2f3013
+DIST python-larch_1.20131130.orig.tar.gz 86509 SHA256 2717e851bde45b66e8b2d44181861f24135d185abab8111119857943d3b5cac1 SHA512 e661fa29043a5254eb3615f0eb54f6afbaf59020607bb72f621083e9f6acfbe92b1c978ce2be73336d8984a4a64ce6d0153556f0af0ca63ad53aff40f785d052 WHIRLPOOL ca777fd5a23270918dc83e92e321413f8bdfee58228ce1224deddbd0d6ae854d1b28b945282fd290053f3cb3b240e6e795eb28c8d687726f2c18f5fda5b716c1
diff --git a/dev-python/larch/larch-1.20130808.ebuild b/dev-python/larch/larch-1.20130808.ebuild
new file mode 100644
index 000000000000..c045d93ddcf8
--- /dev/null
+++ b/dev-python/larch/larch-1.20130808.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Copy-on-write B-tree data structure"
+HOMEPAGE="http://liw.fi/larch/"
+SRC_URI="http://code.liw.fi/debian/pool/main/p/python-${PN}/python-${PN}_${PV}.orig.tar.gz"
+#RESTRICT="test"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-python/CoverageTestRunner dev-util/cmdtest )"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/cliapp
+ dev-python/tracing
+ dev-python/ttystatus"
+
+src_test() {
+ addwrite /proc/self/comm
+ local DISTUTILS_NO_PARALLEL_BUILD=1
+ distutils-r1_src_test
+}
+
+python_test() {
+ emake check
+}
diff --git a/dev-python/larch/larch-1.20131130.ebuild b/dev-python/larch/larch-1.20131130.ebuild
new file mode 100644
index 000000000000..c045d93ddcf8
--- /dev/null
+++ b/dev-python/larch/larch-1.20131130.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Copy-on-write B-tree data structure"
+HOMEPAGE="http://liw.fi/larch/"
+SRC_URI="http://code.liw.fi/debian/pool/main/p/python-${PN}/python-${PN}_${PV}.orig.tar.gz"
+#RESTRICT="test"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-python/CoverageTestRunner dev-util/cmdtest )"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/cliapp
+ dev-python/tracing
+ dev-python/ttystatus"
+
+src_test() {
+ addwrite /proc/self/comm
+ local DISTUTILS_NO_PARALLEL_BUILD=1
+ distutils-r1_src_test
+}
+
+python_test() {
+ emake check
+}
diff --git a/dev-python/larch/metadata.xml b/dev-python/larch/metadata.xml
new file mode 100644
index 000000000000..ea7bd021a21e
--- /dev/null
+++ b/dev-python/larch/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mschiff@gentoo.org</email>
+ <name>Marc Schiffbauer</name>
+ </maintainer>
+</pkgmetadata>