summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-06 06:09:48 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-06 07:02:17 +0100
commit6f244b6eebc64d34ca2f70dfc29b273fde1d4558 (patch)
tree58417f655eaa2ec05966faf9eab1b38b9e364bea /dev-python/jupyter_client
parentapp-arch/libarchive: Add patch to fix CVE-2022-36227. (diff)
downloadgentoo-6f244b6eebc64d34ca2f70dfc29b273fde1d4558.tar.gz
gentoo-6f244b6eebc64d34ca2f70dfc29b273fde1d4558.tar.bz2
gentoo-6f244b6eebc64d34ca2f70dfc29b273fde1d4558.zip
dev-python/jupyter_client: Bump to 7.4.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_client')
-rw-r--r--dev-python/jupyter_client/Manifest1
-rw-r--r--dev-python/jupyter_client/jupyter_client-7.4.8.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/jupyter_client/Manifest b/dev-python/jupyter_client/Manifest
index 8624835a01da..60791430df0b 100644
--- a/dev-python/jupyter_client/Manifest
+++ b/dev-python/jupyter_client/Manifest
@@ -1,3 +1,4 @@
DIST jupyter_client-7.4.4.tar.gz 327373 BLAKE2B 02f70be181779352706f86515f705addbf68383f16d899a4d30c9d6cb0970e955435a8c934f611f93c9fe2eeb5c0fe3b124f31571ae396995564fb450bf03201 SHA512 6de3b271be03ff90d906fc176ce107799abbf8ac882d32d26d86ab91fd3f8a6fa09e5df4f3955e00bc939a31472d423a0d74396f8ba473440c4bc17cc1a28c2f
DIST jupyter_client-7.4.5.tar.gz 327597 BLAKE2B f159d347cf8391c9d3c29327a6c93831e35e7540fb6a0ffe3f59539a7cf5822c562fbb3388ad398a5a6bf87bdd1bc5c6713b9424300d2adb28d93f2a4dafd9c4 SHA512 bef4603222504e40d2ecaf781ea461ba6be8ee32c217e2bf5ec25b83349cec32b3a62e30019ddc75f000bac3fd69ecd6895322f8dcbf953a776dab292b6cca1b
DIST jupyter_client-7.4.7.tar.gz 328801 BLAKE2B 65cd336e99bc6378e78ad99a81907db037fe2271528b06942e056423d9f7e0d45ac595d4dbbb6eced2553d10e36c03e03bb4acc6c25273733043eecf7a3967fb SHA512 ae78496dc130f2188961e61d0874602eb2f8c57586b39377954c1c8247f4dd587eff8e8fd8aec7c8d76beddc661b2aa8f74eb8a37fc667112886232642733195
+DIST jupyter_client-7.4.8.tar.gz 328958 BLAKE2B d05976563c5550ba46a9525c76dae325a107a664c7cc6711fc43333ea9ee747c4b69084e1f4d3118b0baa69bd42781bdd49ce59bf6e608f5520e82e295ffff2c SHA512 dc7eed72ac6c820448e6d8a96c2bee7964706ba608ecaddc8b8aa17f33727ffc04c5a509cd8d7ee78876ce646fc6a508bacdc7b07473555efdad9dd2960ad089
diff --git a/dev-python/jupyter_client/jupyter_client-7.4.8.ebuild b/dev-python/jupyter_client/jupyter_client-7.4.8.ebuild
new file mode 100644
index 000000000000..9938eb0a0424
--- /dev/null
+++ b/dev-python/jupyter_client/jupyter_client-7.4.8.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_client/
+ https://pypi.org/project/jupyter-client/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/entrypoints[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_core-4.9.2[${PYTHON_USEDEP}]
+ >=dev-python/nest_asyncio-1.5.4[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.2[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-23.0[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.0[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipykernel-6.12[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-7.0.6-test-timeout.patch
+)
+
+distutils_enable_tests pytest