summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-15 07:07:47 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-15 07:57:54 +0200
commitb2323fc0c5cc6ee2acf03ecfc71862c95092da09 (patch)
tree1912e77ea3720873a831f89dd41f85cff35d0031 /dev-python/json5
parentapache-2.eclass: add rustls support (diff)
downloadgentoo-b2323fc0c5cc6ee2acf03ecfc71862c95092da09.tar.gz
gentoo-b2323fc0c5cc6ee2acf03ecfc71862c95092da09.tar.bz2
gentoo-b2323fc0c5cc6ee2acf03ecfc71862c95092da09.zip
dev-python/json5: Bump to 0.9.14
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/json5')
-rw-r--r--dev-python/json5/Manifest1
-rw-r--r--dev-python/json5/json5-0.9.14.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/json5/Manifest b/dev-python/json5/Manifest
index a0492fac5922..c1ba27ce2b26 100644
--- a/dev-python/json5/Manifest
+++ b/dev-python/json5/Manifest
@@ -1 +1,2 @@
DIST pyjson5-0.9.11.gh.tar.gz 111445 BLAKE2B 038ac1fab6e56e6dc45dc9bff1fc5e0da21c594cb0ac1f6d888f0207fddace9663b0dbd6abbfabce857cb9fcb40348002b10a6b4133e2f2ebb2081c543e1ad9c SHA512 aca3f38cd79d4bf52ceaf1b3dd27e30bf7598fa0b369216ac820f0c913797ebf542c9eaac17e562ee07006bf83c09210c799bc1b715c7b6e7689d2dcd702d414
+DIST pyjson5-0.9.14.gh.tar.gz 111681 BLAKE2B 7e341f1054da169e95885762f6f801eb9698007c735bfa7d4eb811a4e28a76265cf7215197e16a76184abc41f180ba8895b8120fb8f79bbf1e5f8b397d90c18d SHA512 586746398227d6dfd85c1f5e2cf69f6b4dce9529ffafcbf8d4be49c61196df3f466d5701873d0ab1b0c8851227db0874e1841d1daffcaf18d43efc0e8a171048
diff --git a/dev-python/json5/json5-0.9.14.ebuild b/dev-python/json5/json5-0.9.14.ebuild
new file mode 100644
index 000000000000..24c2cc9239dc
--- /dev/null
+++ b/dev-python/json5/json5-0.9.14.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=pyjson5-${PV}
+DESCRIPTION="A Python implementation of the JSON5 data format"
+HOMEPAGE="
+ https://github.com/dpranke/pyjson5/
+ https://pypi.org/project/json5/
+"
+# no tests in sdist, as of 0.9.14
+SRC_URI="
+ https://github.com/dpranke/pyjson5/archive/refs/tags/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest