summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-30 04:32:02 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-30 04:53:57 +0200
commit706665c5f666e4af62d7a7e7807414fce3b90f6b (patch)
tree76b9fdb246d4763c67a0fd08c48524ac2f2a5367 /dev-python/jaraco-env/jaraco-env-1.0.0.ebuild
parentdev-python/jaraco-functools: Bump to 3.7.0 (diff)
downloadgentoo-706665c5f666e4af62d7a7e7807414fce3b90f6b.tar.gz
gentoo-706665c5f666e4af62d7a7e7807414fce3b90f6b.tar.bz2
gentoo-706665c5f666e4af62d7a7e7807414fce3b90f6b.zip
dev-python/jaraco-env: New NIH for dev-python/pip-run, v1.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jaraco-env/jaraco-env-1.0.0.ebuild')
-rw-r--r--dev-python/jaraco-env/jaraco-env-1.0.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/jaraco-env/jaraco-env-1.0.0.ebuild b/dev-python/jaraco-env/jaraco-env-1.0.0.ebuild
new file mode 100644
index 000000000000..0ffb98b5fc45
--- /dev/null
+++ b/dev-python/jaraco-env/jaraco-env-1.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Facilities for environment variables"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.env/
+ https://pypi.org/project/jaraco.env/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest