summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-14 08:17:34 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-14 09:08:08 +0100
commit06be8ed478cdde03ffb33c81800d50e94d862b0d (patch)
tree256bf7c6c54f151001828342608e81682fe7063c /dev-python/isodate
parentdev-python/py-amqp: Remove old (diff)
downloadgentoo-06be8ed478cdde03ffb33c81800d50e94d862b0d.tar.gz
gentoo-06be8ed478cdde03ffb33c81800d50e94d862b0d.tar.bz2
gentoo-06be8ed478cdde03ffb33c81800d50e94d862b0d.zip
dev-python/isodate: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/isodate')
-rw-r--r--dev-python/isodate/Manifest1
-rw-r--r--dev-python/isodate/files/isodate-0.6.0-py310.patch95
-rw-r--r--dev-python/isodate/isodate-0.6.0-r2.ebuild27
3 files changed, 0 insertions, 123 deletions
diff --git a/dev-python/isodate/Manifest b/dev-python/isodate/Manifest
index 2b123252cee2..b8cafbfbdce8 100644
--- a/dev-python/isodate/Manifest
+++ b/dev-python/isodate/Manifest
@@ -1,2 +1 @@
-DIST isodate-0.6.0.tar.gz 28480 BLAKE2B a7499c736b67193ac73026df7a7c9d9bd5b743a5d556fe5e8ba0a62e8a5238d64afb88547a27e4bcbe706483e3e1e97eecd437e4e1c730c20652cff5926502fc SHA512 e977748e13ee2c94ab47bfc47113d152280e9acff6f70e773de73717392148dd2c111a7db2d9fa3679d37936c6ed9a23dc526cb00bd601df45459b6a244f9f7d
DIST isodate-0.6.1.tar.gz 28443 BLAKE2B 2b451e4dd9a9979feb930090cf045b21c984e962222edc59eff6f08a448258833ac5c368701ed2a703d48c1238122cbe7f628d136124920730bbd96fa04519dc SHA512 437e420ec7ee68dedded825f30d3289eeb0da526208443e5a8e50fe70f12309515e1285b21132d26e6d4c1683f90dfa1d401582042b5e4381fe7ab0e34af26b6
diff --git a/dev-python/isodate/files/isodate-0.6.0-py310.patch b/dev-python/isodate/files/isodate-0.6.0-py310.patch
deleted file mode 100644
index 81b38b48a2a9..000000000000
--- a/dev-python/isodate/files/isodate-0.6.0-py310.patch
+++ /dev/null
@@ -1,95 +0,0 @@
-From 40358ac82b948ea8377d5ca32b576def31b39a84 Mon Sep 17 00:00:00 2001
-From: Jose Eduardo <jose.eduardo.gd@gmail.com>
-Date: Fri, 19 Jul 2019 16:21:56 +0100
-Subject: [PATCH 1/8] Avoid unclosed file warning
-
----
- setup.py | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/setup.py b/setup.py
-index e39446f..9634625 100644
---- a/setup.py
-+++ b/setup.py
-@@ -30,7 +30,8 @@
-
-
- def read(*rnames):
-- return open(os.path.join(os.path.dirname(__file__), *rnames)).read()
-+ with open(os.path.join(os.path.dirname(__file__), *rnames)) as read_file:
-+ return read_file.read()
-
-
- setup(name='isodate',
-
-From 91bf24dd1610d5f6ac5d4867457f0703046017d2 Mon Sep 17 00:00:00 2001
-From: Jose Eduardo <jose.eduardo.gd@gmail.com>
-Date: Fri, 19 Jul 2019 16:22:22 +0100
-Subject: [PATCH 2/8] Raise warnings produced by isodate as errors during tests
-
----
- src/isodate/tests/__init__.py | 3 +++
- tox.ini | 2 ++
- 2 files changed, 5 insertions(+)
-
-diff --git a/src/isodate/tests/__init__.py b/src/isodate/tests/__init__.py
-index b1d46bd..7208cbd 100644
---- a/src/isodate/tests/__init__.py
-+++ b/src/isodate/tests/__init__.py
-@@ -29,6 +29,7 @@
- '''
-
- import unittest
-+import warnings
- from isodate.tests import (test_date, test_time, test_datetime, test_duration,
- test_strf, test_pickle)
-
-@@ -37,6 +38,8 @@ def test_suite():
- '''
- Return a new TestSuite instance consisting of all available TestSuites.
- '''
-+ warnings.filterwarnings("error", module=r"isodate(\..)*")
-+
- return unittest.TestSuite([
- test_date.test_suite(),
- test_time.test_suite(),
-
-From fc0fb3278da5f463ca5b2f0a3acafbbf2869bd7a Mon Sep 17 00:00:00 2001
-From: Jose Eduardo <jose.eduardo.gd@gmail.com>
-Date: Fri, 19 Jul 2019 16:29:43 +0100
-Subject: [PATCH 4/8] Fix Python 3.8 DeprecationWarning
-
-Ref: https://docs.python.org/3.8/whatsnew/3.8.html
-
-> Many builtin and extension functions that take integer arguments will
-> now emit a deprecation warning for Decimals, Fractions and any other
-> objects that can be converted to integers only with a loss (e.g. that
-> have the `__int__()` method but do not have the `__index__()` method).
-> In future version they will be errors. (Contributed by Serhiy
-> Storchaka in bpo-36048.)
----
- src/isodate/duration.py | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/isodate/duration.py b/src/isodate/duration.py
-index 6d1848c..d923cee 100644
---- a/src/isodate/duration.py
-+++ b/src/isodate/duration.py
-@@ -180,7 +180,7 @@ def __add__(self, other):
- newday = maxdays
- else:
- newday = other.day
-- newdt = other.replace(year=newyear, month=newmonth, day=newday)
-+ newdt = other.replace(year=int(newyear), month=int(newmonth), day=newday)
- # does a timedelta + date/datetime
- return self.tdelta + newdt
- except AttributeError:
-@@ -264,7 +264,7 @@ def __rsub__(self, other):
- newday = maxdays
- else:
- newday = other.day
-- newdt = other.replace(year=newyear, month=newmonth, day=newday)
-+ newdt = other.replace(year=int(newyear), month=int(newmonth), day=newday)
- return newdt - self.tdelta
- except AttributeError:
- # other probably was not compatible with data/datetime
diff --git a/dev-python/isodate/isodate-0.6.0-r2.ebuild b/dev-python/isodate/isodate-0.6.0-r2.ebuild
deleted file mode 100644
index a7b6227bc1e5..000000000000
--- a/dev-python/isodate/isodate-0.6.0-r2.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="ISO 8601 date/time/duration parser and formatter"
-HOMEPAGE="https://pypi.org/project/isodate/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-
-distutils_enable_tests unittest
-
-PATCHES=(
- "${FILESDIR}"/${P}-py310.patch
-)
-
-python_test() {
- eunittest -s "${BUILD_DIR}/lib"
-}