summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-28 19:55:12 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-28 20:32:53 +0200
commit34bb49423c0346ecbe6077e930a7062668850087 (patch)
treeabd54cfaef8f534b3d4345981f6d57fc2ecdae27 /dev-python/iso8601
parentwww-apps/element: 1.11.8 bump, remove security vulnerable versions (diff)
downloadgentoo-34bb49423c0346ecbe6077e930a7062668850087.tar.gz
gentoo-34bb49423c0346ecbe6077e930a7062668850087.tar.bz2
gentoo-34bb49423c0346ecbe6077e930a7062668850087.zip
dev-python/iso8601: Bump to 1.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/iso8601')
-rw-r--r--dev-python/iso8601/Manifest1
-rw-r--r--dev-python/iso8601/iso8601-1.1.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/iso8601/Manifest b/dev-python/iso8601/Manifest
index dcd6c6b1adbb..0901b0590388 100644
--- a/dev-python/iso8601/Manifest
+++ b/dev-python/iso8601/Manifest
@@ -1 +1,2 @@
DIST iso8601-1.0.2.tar.gz 12653 BLAKE2B c7dbbe680f2828050b2ff32765da009b5f6dafdbc5182d5136f951f8604d7ff579b85050dbefae47d2b28ce88515b9dd73a8abf73b3419b4cdc4a4dd275b7228 SHA512 f28fbfe82c25575ad73a92df144c108ef3cf4e1a5a9af8362187014904073f26daa3b77dde689a23cfd87cdbf86196b241e925dd8cf5fd81728f0dbeee4836b7
+DIST iso8601-1.1.0.tar.gz 12836 BLAKE2B 7860d52002008a76c1d28ae94abe5100c3ea434f8e19dcb677dfc84366e898d2d277d88e6591d663579281c4ee668e77db96fd586edbe8b027433844462071e9 SHA512 f3f9621863abcbcde467d38416391cd8c98f59b7b863845b670e11060f0f81bcf4979fadc51c19eb55a5fe44ee1af922976b11cc97bf7b2dc090a485ad9979ac
diff --git a/dev-python/iso8601/iso8601-1.1.0.ebuild b/dev-python/iso8601/iso8601-1.1.0.ebuild
new file mode 100644
index 000000000000..853630b33634
--- /dev/null
+++ b/dev-python/iso8601/iso8601-1.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple module to parse ISO 8601 dates"
+HOMEPAGE="
+ https://github.com/micktwomey/pyiso8601/
+ https://pypi.org/project/iso8601/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest