summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-29 15:56:26 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 15:56:57 +0100
commit35166b74bbb86f4234ca9caeee0c545461d9870b (patch)
treeb41d17bef0e5c4f7ac0bc1dc89e6208804a81893 /dev-python/ipaddr
parentdev-python/httpauth: Switch to PEP 517 build (diff)
downloadgentoo-35166b74bbb86f4234ca9caeee0c545461d9870b.tar.gz
gentoo-35166b74bbb86f4234ca9caeee0c545461d9870b.tar.bz2
gentoo-35166b74bbb86f4234ca9caeee0c545461d9870b.zip
dev-python/ipaddr: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ipaddr')
-rw-r--r--dev-python/ipaddr/ipaddr-2.2.0-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/ipaddr/ipaddr-2.2.0-r2.ebuild b/dev-python/ipaddr/ipaddr-2.2.0-r2.ebuild
new file mode 100644
index 000000000000..cf3c4704e910
--- /dev/null
+++ b/dev-python/ipaddr/ipaddr-2.2.0-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python IP address manipulation library"
+HOMEPAGE="https://github.com/google/ipaddr-py https://pypi.org/project/ipaddr/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+src_configure() {
+ 2to3 -n -w --no-diffs *.py || die
+}
+
+python_test() {
+ "${EPYTHON}" ipaddr_test.py || die "Tests fail with ${EPYTHON}"
+}