summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-04-28 13:24:53 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-04-28 14:02:29 -0700
commit0f6a64d9b0a5715bf048ed592a690866f645aab5 (patch)
treeaba0105cf3a2b20410865db48b84f3e80e20b1e0 /dev-python/ioflo
parentgames-misc/exult-sound: QA Fix missing unzip (diff)
downloadgentoo-0f6a64d9b0a5715bf048ed592a690866f645aab5.tar.gz
gentoo-0f6a64d9b0a5715bf048ed592a690866f645aab5.tar.bz2
gentoo-0f6a64d9b0a5715bf048ed592a690866f645aab5.zip
dev-python/ioflo-1.7.8: Version bump
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/ioflo')
-rw-r--r--dev-python/ioflo/Manifest1
-rw-r--r--dev-python/ioflo/files/ioflo-1.7.8-network-test.patch32
-rw-r--r--dev-python/ioflo/ioflo-1.7.8.ebuild26
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/ioflo/Manifest b/dev-python/ioflo/Manifest
index c35fb8a1726a..c191ce0d46f6 100644
--- a/dev-python/ioflo/Manifest
+++ b/dev-python/ioflo/Manifest
@@ -1 +1,2 @@
DIST ioflo-1.7.5.tar.gz 838342 BLAKE2B 2eff6af7586400ff562999679b861079184757c951e006d2f300ec894dd17fa9c2ed975781109f6d3bd2cabf0e038ccf81d9f9aeac742313eedaabb59b5a1c82 SHA512 886767d72c4067727d47652fba157a76ecd8a6a5478a761feb3923992ffc585addfe892027ade104c5d44a56fd1645c0548ce3b554553f58e1104864c359470b
+DIST ioflo-1.7.8.tar.gz 838925 BLAKE2B 2df2635990292c416cd4dc3bed5efedce29e494e2488ef5d23294e06ccaaa7f148fd5115ada0fb19dedfc090038ace48027d0bd9eb84a2e2c2c2be223ef2e4eb SHA512 eb6c8e28b915860184beef80281c6d0b0ade851a0d5727005abeca48ee23ba6711de2e1733d2d83d195eb88c0382a626cd7f8e3b5d24d4162409d1d67b225c95
diff --git a/dev-python/ioflo/files/ioflo-1.7.8-network-test.patch b/dev-python/ioflo/files/ioflo-1.7.8-network-test.patch
new file mode 100644
index 000000000000..32c7f51298ce
--- /dev/null
+++ b/dev-python/ioflo/files/ioflo-1.7.8-network-test.patch
@@ -0,0 +1,32 @@
+diff --git a/ioflo/aio/udp/test/test_udping.py b/ioflo/aio/udp/test/test_udping.py
+index 9aefdf0..ec44721 100644
+--- a/ioflo/aio/udp/test/test_udping.py
++++ b/ioflo/aio/udp/test/test_udping.py
+@@ -122,6 +122,7 @@ class BasicTestCase(unittest.TestCase):
+ shutil.rmtree(tempDirpath)
+ console.reinit(verbosity=console.Wordage.concise)
+
++ @unittest.skip("needs network access")
+ def testBroadcast(self):
+ """
+ Test Class SocketUdpNb
+diff --git a/ioflo/base/test/test_logging.py b/ioflo/base/test/test_logging.py
+index 0b8ce13..b64d469 100644
+--- a/ioflo/base/test/test_logging.py
++++ b/ioflo/base/test/test_logging.py
+@@ -33,6 +33,7 @@ def tearDownModule():
+ console.reinit(verbosity=console.Wordage.concise)
+
+
++@unittest.skip("needs network access")
+ class LoggerTestCase(testing.LoggerIofloTestCase):
+ """
+ Example TestCase
+@@ -927,6 +928,7 @@ class LoggerTestCase(testing.LoggerIofloTestCase):
+ pass
+
+
++@unittest.skip("needs network access")
+ class HouseTestCase(testing.HouseIofloTestCase):
+ """
+ Example TestCase
diff --git a/dev-python/ioflo/ioflo-1.7.8.ebuild b/dev-python/ioflo/ioflo-1.7.8.ebuild
new file mode 100644
index 000000000000..ee4358922717
--- /dev/null
+++ b/dev-python/ioflo/ioflo-1.7.8.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_6)
+inherit distutils-r1
+
+DESCRIPTION="Automated Reasoning Engine and Flow Based Programming Framework"
+HOMEPAGE="https://github.com/ioflo/ioflo/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}/ioflo-1.7.8-network-test.patch"
+)
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ sed -e 's:"setuptools_git[^"]*",::' -i setup.py || die
+ distutils-r1_python_prepare_all
+}