summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-11-06 08:20:28 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-11-06 09:17:01 +0100
commite1e2fd463861bf78ecaa92232d6fae7eb80e9316 (patch)
treefdc29e9f912a3c45f344c8cb4fc5855b8c349ad1 /dev-python/hypothesis
parentdev-util/jenkins-bin: Bump (diff)
downloadgentoo-e1e2fd463861bf78ecaa92232d6fae7eb80e9316.tar.gz
gentoo-e1e2fd463861bf78ecaa92232d6fae7eb80e9316.tar.bz2
gentoo-e1e2fd463861bf78ecaa92232d6fae7eb80e9316.zip
dev-python/hypothesis: Bump
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-3.6.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 66d5ad2eb33e..f21652362840 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1,3 +1,4 @@
DIST hypothesis-1.19.0.tar.gz 86227 SHA256 0e977a3492f5488ed9dd4a872cefae0934ad4ccd0229a6c483ef5ca0aaaddd6d SHA512 3b2cd671498bd0bc88c93b2753f35b02f737533dd8dbc786420a37a417d145e4f1c579741966394f85b7df4939e61f77315e6158b29e22f9bde07d31e161e009 WHIRLPOOL 52b444e6e3fa0c514ebb9816cd489b2441b213581e241f76ab5aa5c410ca08bedef92f0b608c32c421f74ba84a0e26850a2aaf9f2d9f7229aa176d9e501175a0
DIST hypothesis-3.4.2.tar.gz 71270 SHA256 87a6b96670d52d9c30fff1342adec178822cd472775588d998bd860c05409688 SHA512 355815a11c57448a175a984d1ad6e87dcd9cc954acf312bfeff4ec499678166be6b9751173307748ff8b2d325b502cd31151e883e2a52f2d51a0395436bdb039 WHIRLPOOL 839bdc774f3889b0243119a81a9caa9eb29918dbf79ed7f5d7a1d15bab2e2ad6cfcd41948ab8b249c7bfecec3271aab99724b2eb2bde340136d9d9253f1fdeef
DIST hypothesis-3.5.3.tar.gz 73052 SHA256 25bdf9bd507f6c66b33c11c8c8ba31c3a6a6969e9b2035554fde69ceed84633d SHA512 1b22715e3ead84075d58c3e6ddfc074f542b2bce077e4e63fadd5910266bad81b3393b8a5c8d3b77e6f73e6987428fc92bd38a2d02003b5f490dd4ce08bca34c WHIRLPOOL 61ae670ca5167bdf5dae3fccb53bca9504d7470a6a5f159e5631b8a772da66f94ef5f0113029f189137757a70c261fb8ec2efdc2e92ab9060f19cdf4a1156698
+DIST hypothesis-3.6.0.tar.gz 73586 SHA256 ecb0e711ab83032c54605d88fda1e07ca5c6025bdb5e91deab96eca29491f678 SHA512 cb885628e5c38ab9312cfb177ebc3c014617d21031737f5fba343ba485c1b8ff82b1302e7bc1d3e79192bfd8324fd0501498c968f3ac8343829f8965f6354389 WHIRLPOOL 189c788fdd0a326879a468061c271b14056da5f7dc1d5975e8f360cd5a91957eb8f79c26a045fbe49d7b11f7cc09024d3d09a353321b1dda1d4d96b452fd9e7b
diff --git a/dev-python/hypothesis/hypothesis-3.6.0.ebuild b/dev-python/hypothesis/hypothesis-3.6.0.ebuild
new file mode 100644
index 000000000000..30fce5cbc8cd
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-3.6.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/DRMacIver/hypothesis https://pypi.python.org/pypi/hypothesis"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7)
+ dev-python/uncompyle6[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pytest support" dev-python/pytest
+# optfeature "fake-factory support" dev-python/fake-factory
+}