summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-28 06:33:03 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-28 06:33:03 +0200
commit019247b9ab5e1f782b962b8283da5e4bd5fb4689 (patch)
treeba850cc24da6c185406e94b769593855e2f55c7d /dev-python/hypothesis
parentdev-python/scipy: Remove old (diff)
downloadgentoo-019247b9ab5e1f782b962b8283da5e4bd5fb4689.tar.gz
gentoo-019247b9ab5e1f782b962b8283da5e4bd5fb4689.tar.bz2
gentoo-019247b9ab5e1f782b962b8283da5e4bd5fb4689.zip
dev-python/hypothesis: Bump to 6.74.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.74.1.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index c8c41cbb793d..e933af455fae 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -2,3 +2,4 @@ DIST hypothesis-6.71.0.gh.tar.gz 9357031 BLAKE2B e4a83a94bb6971c3ecba4cc69655f9d
DIST hypothesis-6.72.1.gh.tar.gz 9358351 BLAKE2B fbb760194c944cc939e9a9b83a461be22f9e5081d865f0dfa3834375d464714178dca64b9e1993fa4b0855e90f6e133a81d22699acc91560f60f137e8589798c SHA512 1a9d4b103f714e27ec5e33efbdfda0cc3febbe77caf6f605db7fb3b2df857712682a3cce80e75f45f9cd88b1715789d7fc2c5a7d50edbf66a699f5381e2671e5
DIST hypothesis-6.72.2.gh.tar.gz 9358396 BLAKE2B 0f93935523f0f56ec570f1434d33ac7fc51ef57a37c439a8982f6e4be9177fb3eeaa997861541b79857f70d2118501a4ee8feb106face33fc714544c176a9729 SHA512 b7dc8832fc487f263c4bfa3ed1d172bbb1e5ecc4b5bf82cdbe456dd935b2c2541bbd663b16f51d1bacf47caec864ba970f470f68557a72e808d1e5a3067e7531
DIST hypothesis-6.72.4.gh.tar.gz 9358883 BLAKE2B c877e98140d767b7ac5c9c968f21f1ae26fc7405a740fcdeafb3191a7608da17791b49ef769f0373efeb39a1ef16a519335072dff2a6b88a71b300eea4266dad SHA512 e94b7c70f775337084f43cfd8088a43919383a66f4e8896e1a9bc27e282a718083b3a38c49c25e57eb22688a7fbd8f76fb8809a42cd0d7c4dbc69a415cbe952a
+DIST hypothesis-6.74.1.gh.tar.gz 9364092 BLAKE2B 917b98aa86319c902aff8dd7603b02e94722a4d4b22428bd981f130d2dfac3c85eb5a15c98486ea709ce9f4f6ef2f882a6c3263b650128349a2fb0737b134728 SHA512 ad6e53579434c15ae843d827590275955848575e8f10899178289f19ae7b5c23a60bb2ac329ed782e2018635ac5c62fc08336c3454ebe1987fdf64d4ec4cb5a6
diff --git a/dev-python/hypothesis/hypothesis-6.74.1.ebuild b/dev-python/hypothesis/hypothesis-6.74.1.ebuild
new file mode 100644
index 000000000000..6173a4ae7bc6
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.74.1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/requests-toolbelt-0.10.1
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
+
+ # NB: paths need to be relative to pytest.ini,
+ # i.e. start with hypothesis-python/
+ local EPYTEST_DESELECT=()
+ if [[ ${EPYTHON} == pypy3 ]]; then
+ EPYTEST_DESELECT+=(
+ # failing due to warnings from numpy/cython
+ hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
+ )
+ fi
+
+ epytest -o filterwarnings= -n "$(makeopts_jobs)" \
+ tests/cover tests/pytest tests/quality
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}