summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-11-30 21:19:53 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-11-30 21:41:56 +0200
commitce99357ea02fc2610e5d6015774fd7ef5782d834 (patch)
tree79d6ed83ac256ffc2cf58337c027f2d8309a46df /dev-python/gsd
parentnet-analyzer/netdata: add 1.37.0 (diff)
downloadgentoo-ce99357ea02fc2610e5d6015774fd7ef5782d834.tar.gz
gentoo-ce99357ea02fc2610e5d6015774fd7ef5782d834.tar.bz2
gentoo-ce99357ea02fc2610e5d6015774fd7ef5782d834.zip
dev-python/gsd: add 2.7.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/gsd')
-rw-r--r--dev-python/gsd/Manifest1
-rw-r--r--dev-python/gsd/gsd-2.7.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/gsd/Manifest b/dev-python/gsd/Manifest
index 9e307130cdcc..32a3b9a47193 100644
--- a/dev-python/gsd/Manifest
+++ b/dev-python/gsd/Manifest
@@ -1 +1,2 @@
DIST gsd-v2.6.1.tar.gz 106134 BLAKE2B 2b2e54c9ee654f384340c642e52a9c154520490c48ec87b31a7186b2ccd494cf4918620c999456d03e128a0b36b588e4dc180904f5f553aef832e7e217e60a56 SHA512 732d291e410a47885449584bf09521398075e3074c4abe49301f07f4cb30a6841c2ddc8431d8aadbc4896f61cf32605b22422b7278da26827c303b4f6476e459
+DIST gsd-v2.7.0.tar.gz 106584 BLAKE2B 9a37d04f2c975d84f8f2d23080cd934bcec3025e8a3047483a809527bc51424c5729966482bafe9c996c8e4c7c7f1594fc8292316f46dd676e6a88ad7b0360c2 SHA512 042c3ce97183068031a754e3e5676effd4d1e30406ac24e06510c72d2ceef22fdb8c62866cf7884aa578f18eadb1f7cb5385ebddfc8ede426a4fee6ecb7fb9fa
diff --git a/dev-python/gsd/gsd-2.7.0.ebuild b/dev-python/gsd/gsd-2.7.0.ebuild
new file mode 100644
index 000000000000..fd7b6e2d2c6e
--- /dev/null
+++ b/dev-python/gsd/gsd-2.7.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=${P/-/-v}
+DESCRIPTION="GSD - file format specification and a library to read and write it"
+HOMEPAGE="
+ https://github.com/glotzerlab/gsd/
+ https://pypi.org/project/gsd/
+"
+SRC_URI="
+ https://github.com/glotzerlab/gsd/releases/download/v${PV}/${MY_P}.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=dev-python/numpy-1.23.4[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd "${T}" || die
+ epytest --pyargs gsd
+}