summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-04-16 18:24:31 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-04-16 18:36:15 +0300
commit9b5cd8281145ea54295cc1a55bd99024502b94da (patch)
treeff169fe4d942b9bb9da66c87cda5791c4db9165f /dev-python/gsd
parentdev-python/pyocr: add 0.8.2 (diff)
downloadgentoo-9b5cd8281145ea54295cc1a55bd99024502b94da.tar.gz
gentoo-9b5cd8281145ea54295cc1a55bd99024502b94da.tar.bz2
gentoo-9b5cd8281145ea54295cc1a55bd99024502b94da.zip
dev-python/gsd: add 2.5.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/gsd')
-rw-r--r--dev-python/gsd/Manifest1
-rw-r--r--dev-python/gsd/gsd-2.5.2.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/gsd/Manifest b/dev-python/gsd/Manifest
index dd4613acd102..7e943548d5fc 100644
--- a/dev-python/gsd/Manifest
+++ b/dev-python/gsd/Manifest
@@ -1 +1,2 @@
DIST gsd-v2.5.0.tar.gz 105537 BLAKE2B dbd9cef142405bae4e99c180f6b7c65cb60240fe45e200643b8efd388c72830a70d97c649fdb686afeed4eb44386cbe68165ed105bd67424f1cbd3657159c16a SHA512 f5eda751bdfa4d3eae980029fe5594fc5698d68265784f089b0997441c18f58d70d71cf52a0b4fd208708aba0162164d1f640440964b6e211db856f10c7c0c67
+DIST gsd-v2.5.2.tar.gz 105448 BLAKE2B 408e66a91ea056e8c863e23dae439009e5f802f38d5e2a3b89bbb07c574ad61827fa9c2767729c37dcc8fa7ecb1fc3be922755da0ac0dc922ead2a365ce66a10 SHA512 2a2afb56b9f836608523b2946a0d2ca94511457506d02038d496b374ccb96dc0daad6435f9ee63b0937837b725d6288325c066d75d2ac0b0c6d9da4beb9eb082
diff --git a/dev-python/gsd/gsd-2.5.2.ebuild b/dev-python/gsd/gsd-2.5.2.ebuild
new file mode 100644
index 000000000000..296fe8d78986
--- /dev/null
+++ b/dev-python/gsd/gsd-2.5.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_P=${P/-/-v}
+DESCRIPTION="GSD - file format specification and a library to read and write it"
+HOMEPAGE="https://github.com/glotzerlab/gsd"
+SRC_URI="https://github.com/glotzerlab/gsd/releases/download/v${PV}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+RDEPEND=${DEPEND}
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd "${T}" || die
+ epytest --pyargs gsd
+}