summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-23 05:31:47 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-23 05:38:51 +0100
commit57f54c3f2f2f9192426921dbe6ac9c378097c6bf (patch)
treea11e90ce023a4c74f1bb9de017a7fb0eed6127c6 /dev-python/gsd
parentdev-python/jupyter-server-terminals: Bump to 0.5.2 (diff)
downloadgentoo-57f54c3f2f2f9192426921dbe6ac9c378097c6bf.tar.gz
gentoo-57f54c3f2f2f9192426921dbe6ac9c378097c6bf.tar.bz2
gentoo-57f54c3f2f2f9192426921dbe6ac9c378097c6bf.zip
dev-python/gsd: Bump to 3.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/gsd')
-rw-r--r--dev-python/gsd/Manifest1
-rw-r--r--dev-python/gsd/gsd-3.2.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/gsd/Manifest b/dev-python/gsd/Manifest
index 36601fec179a..4e09af2fbc15 100644
--- a/dev-python/gsd/Manifest
+++ b/dev-python/gsd/Manifest
@@ -1 +1,2 @@
DIST gsd-3.2.0.tar.gz 107175 BLAKE2B e5bcd1ec39066b872efba605dbbe316cd957341c45c5c3fecbc6d1653f91b2cd9154ecdd8123aedf697608dfa1f311996e088724e803929399395befe062a58d SHA512 4bc4d5a4186234d339e488db7c1f4efc6e0a2afe9b1d1ca8d75f65ae25119a2782311bfbc000ab12668fe4326fa737509c16d447252693becf6218ac8d22921f
+DIST gsd-3.2.1.tar.gz 108463 BLAKE2B d944a1a7f991e0894bfa1e42aa891ed02f0bbbf91efda39ab45b87f21c17bcc16251a51a34682efb67b6b85cf7fc9d6d92108d85d9643ab8e19aed584397779f SHA512 e889b72d3857d41e68d9515d5857d99f8f6ceead4b8a43019ddf11c4600054c7af3e046792ce154031bfb439c57ecd9d0e553a574cbbf7bce2578b90da631230
diff --git a/dev-python/gsd/gsd-3.2.1.ebuild b/dev-python/gsd/gsd-3.2.1.ebuild
new file mode 100644
index 000000000000..367cf1319642
--- /dev/null
+++ b/dev-python/gsd/gsd-3.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="GSD - file format specification and a library to read and write it"
+HOMEPAGE="
+ https://github.com/glotzerlab/gsd/
+ https://pypi.org/project/gsd/
+"
+SRC_URI="
+ https://github.com/glotzerlab/gsd/releases/download/v${PV}/${P}.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=dev-python/numpy-1.24.2[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd "${T}" || die
+ epytest --pyargs gsd
+}