summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-30 05:41:01 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-30 06:02:58 +0200
commit0490d8f728608d9a43ca26bb0e1998aa9bc36687 (patch)
tree126a8eedc8f9904bb8dde16c6cd04b85e72ccc92 /dev-python/gsd
parentdev-python/sqlglot: Bump to 24.0.3 (diff)
downloadgentoo-0490d8f728608d9a43ca26bb0e1998aa9bc36687.tar.gz
gentoo-0490d8f728608d9a43ca26bb0e1998aa9bc36687.tar.bz2
gentoo-0490d8f728608d9a43ca26bb0e1998aa9bc36687.zip
dev-python/gsd: Bump to 3.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/gsd')
-rw-r--r--dev-python/gsd/Manifest1
-rw-r--r--dev-python/gsd/gsd-3.3.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/gsd/Manifest b/dev-python/gsd/Manifest
index 788096f40a97..3ea7ca0ce492 100644
--- a/dev-python/gsd/Manifest
+++ b/dev-python/gsd/Manifest
@@ -1 +1,2 @@
DIST gsd-3.2.1.tar.gz 108463 BLAKE2B d944a1a7f991e0894bfa1e42aa891ed02f0bbbf91efda39ab45b87f21c17bcc16251a51a34682efb67b6b85cf7fc9d6d92108d85d9643ab8e19aed584397779f SHA512 e889b72d3857d41e68d9515d5857d99f8f6ceead4b8a43019ddf11c4600054c7af3e046792ce154031bfb439c57ecd9d0e553a574cbbf7bce2578b90da631230
+DIST gsd-3.3.0.tar.gz 108961 BLAKE2B 1f734534717af776ebb5a62ddf67eabcc5bc99a814e48ac8d962fc034f24e4eb87a3e45087f3e2f7db757bfd57e44668e41a3ca1fccf406d964024a3a2d399ae SHA512 f01017f46626d19ae5e5bf683c719d6f74b0f3a9d295cd2e54d736f8ca9c25740389b9701b636b2513039919d52e6a6193215cdf759c1f5d3e686071c3888c27
diff --git a/dev-python/gsd/gsd-3.3.0.ebuild b/dev-python/gsd/gsd-3.3.0.ebuild
new file mode 100644
index 000000000000..a16117a836ec
--- /dev/null
+++ b/dev-python/gsd/gsd-3.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="GSD - file format specification and a library to read and write it"
+HOMEPAGE="
+ https://github.com/glotzerlab/gsd/
+ https://pypi.org/project/gsd/
+"
+SRC_URI="
+ https://github.com/glotzerlab/gsd/releases/download/v${PV}/${P}.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=dev-python/numpy-1.24.2[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd "${T}" || die
+ epytest --pyargs gsd
+}