summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-28 21:26:38 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-28 21:36:40 +0200
commitf68422a21b36566e3b9f02d679017ed709311b29 (patch)
tree85bb99c7a3b4867ac200901d3d89448550ab9e0e /dev-python/grpclib/grpclib-0.4.7-r1.ebuild
parentmedia-gfx/fotema: Bump to 1.14.3 (diff)
downloadgentoo-f68422a21b36566e3b9f02d679017ed709311b29.tar.gz
gentoo-f68422a21b36566e3b9f02d679017ed709311b29.tar.bz2
gentoo-f68422a21b36566e3b9f02d679017ed709311b29.zip
dev-python/grpclib: Fix dependencies
Closes: https://bugs.gentoo.org/940453 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/grpclib/grpclib-0.4.7-r1.ebuild')
-rw-r--r--dev-python/grpclib/grpclib-0.4.7-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/grpclib/grpclib-0.4.7-r1.ebuild b/dev-python/grpclib/grpclib-0.4.7-r1.ebuild
new file mode 100644
index 000000000000..5e8fea8ee179
--- /dev/null
+++ b/dev-python/grpclib/grpclib-0.4.7-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python gRPC implementation for asyncio"
+HOMEPAGE="
+ https://github.com/vmagamedov/grpclib/
+ https://pypi.org/project/grpclib/
+"
+# no tests in sdist, as of 0.4.7
+SRC_URI="
+ https://github.com/vmagamedov/grpclib/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# setup.txt + requirements/runtime.in
+RDEPEND="
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/googleapis-common-protos[${PYTHON_USEDEP}]
+ dev-python/h2[${PYTHON_USEDEP}]
+ dev-python/multidict[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/async-timeout[${PYTHON_USEDEP}]
+ dev-python/Faker[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest