summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-18 16:47:27 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-18 16:47:27 +0200
commit4b6664be0503babb61380dc98713b9d161690f97 (patch)
treedd6b56a2d4cae73ef9d2f758d2eb5ec9b62953f0 /dev-python/gevent
parentdev-python/fsspec: Remove old (diff)
downloadgentoo-4b6664be0503babb61380dc98713b9d161690f97.tar.gz
gentoo-4b6664be0503babb61380dc98713b9d161690f97.tar.bz2
gentoo-4b6664be0503babb61380dc98713b9d161690f97.zip
dev-python/gevent: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/gevent')
-rw-r--r--dev-python/gevent/Manifest1
-rw-r--r--dev-python/gevent/gevent-20.6.0.ebuild90
2 files changed, 0 insertions, 91 deletions
diff --git a/dev-python/gevent/Manifest b/dev-python/gevent/Manifest
index 344eba426d5f..a5155708321a 100644
--- a/dev-python/gevent/Manifest
+++ b/dev-python/gevent/Manifest
@@ -1,2 +1 @@
-DIST gevent-20.6.0.tar.gz 5803237 BLAKE2B 97b988964ef80fcc1c3238718b6802016fb46742c94e7e56b5196139181ff82ce60816e0a8ccc5c3e1c3b73ec11cc705884b5ac5524dbd5116dc0d8722ccc7a4 SHA512 28ee030934d3c379577c9f86b76838e5d76c7ea7c0880cdeac9dc5ead497ae0600fb02b2984c7312fd42319142200c674b75da2e93b58fd4a99882d601a95108
DIST gevent-20.6.2.tar.gz 5806612 BLAKE2B 8b1fbd991cb169292d33001bb0df06702d36eb3849c9251e4fac9e2fb5826eda3435971e39e209f1f537536081ce2730e561e91c398ee66a9b1d55c9d0e5a81a SHA512 65caa9caf8a2913b4c3bcc9a303169ce5837a0d7ccf4fb6b7583bf4ec3a0b288d65fc7e28399f0715e61aed128ffc6e67fc9b455474e47263236136a492021f4
diff --git a/dev-python/gevent/gevent-20.6.0.ebuild b/dev-python/gevent/gevent-20.6.0.ebuild
deleted file mode 100644
index 2cad389df36a..000000000000
--- a/dev-python/gevent/gevent-20.6.0.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} )
-PYTHON_REQ_USE="ssl(+),threads(+)"
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Coroutine-based network library"
-HOMEPAGE="https://www.gevent.org/ https://pypi.org/project/gevent/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~mips ppc ppc64 s390 ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-libs/libev-4.23:=
- dev-libs/libuv:=
- >=net-dns/c-ares-1.12:=
- >=dev-python/greenlet-0.4.14
- virtual/python-greenlet[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/zope-event[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/futures[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- ' -2)
- )"
-
-distutils_enable_sphinx doc
-
-# Tests take long and fail terribly a few times.
-# It also seems that they require network access.
-#RESTRICT="test"
-
-python_prepare_all() {
- export LIBEV_EMBED="false"
- export CARES_EMBED="false"
- export EMBED="false"
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- append-flags -fno-strict-aliasing
-}
-
-python_test() {
- cd src/gevent/tests || die
- # TODO: figure out how to make them work and not hang
-# GEVENT_RESOLVER=ares \
-# "${EPYTHON}" -m gevent.tests \
-# -uall,-network \
-# --config known_failures.py \
-# --ignore tests_that_dont_use_resolver.txt || die
-# GEVENT_RESOLVER=dnspython \
-# "${EPYTHON}" -m gevent.tests \
-# -uall,-network \
-# --config known_failures.py \
-# --ignore tests_that_dont_use_resolver.txt || die
-# GEVENT_RESOLVER=thread \
-# "${EPYTHON}" -m gevent.tests \
-# --verbose \
-# -uall,-network \
-# --config known_failures.py \
-# --ignore tests_that_dont_use_resolver.txt || die
- GEVENT_FILE=thread \
- "${EPYTHON}" -m gevent.tests \
- --verbose \
- -uall,-network \
- --config known_failures.py \
- test__*subprocess*.py || die
-}
-
-python_install_all() {
- local DOCS=( AUTHORS README.rst )
- use examples && dodoc -r examples
-
- distutils-r1_python_install_all
-}