summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-11 09:08:34 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-11 09:56:54 +0200
commit121ce41dac320cbb256e6711b79ad08b0161d696 (patch)
tree616ffb7c8ce78781d4a1a3e993eedc11d3a26ad1 /dev-python/flit
parentdev-python/tomli-w: New package, dep of dev-python/flit (diff)
downloadgentoo-121ce41dac320cbb256e6711b79ad08b0161d696.tar.gz
gentoo-121ce41dac320cbb256e6711b79ad08b0161d696.tar.bz2
gentoo-121ce41dac320cbb256e6711b79ad08b0161d696.zip
dev-python/flit: Bump to 3.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flit')
-rw-r--r--dev-python/flit/Manifest1
-rw-r--r--dev-python/flit/flit-3.4.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/flit/Manifest b/dev-python/flit/Manifest
index 84ed16c295b1..a54854c5e95d 100644
--- a/dev-python/flit/Manifest
+++ b/dev-python/flit/Manifest
@@ -1,3 +1,4 @@
DIST flit-2.1.0.tar.gz 106459 BLAKE2B db51d8cc119ae8aa5f8d0ac1655cd29390065567391cbdf06ca7dbb98a79e96a6d8f318273c2f9a58aaf549090a903360701a844ac071d15304a21ea54052a91 SHA512 0fcbfaa1e5e83216a5c98cc87b0a8f2aa17e2c184ec3f09c7dd0dd5e695311be62344ac4f101cb71f87390513496f8c1152a2cd8d7363202f7696ee002f07a55
DIST flit-3.2.0.tar.gz 115192 BLAKE2B dda4b9f5b56b9868d737516841d7fc49c0e97ef8a71f9f0628112f68c3dadae89a87aef56cebfe8ec3762af5970d206fe462add146d52b3893fb8852fd7f9625 SHA512 1db7c4118fe1d70d1e318db3bc282747d6cc3f3b626ad68420fa056e585caad9ff0a3f230e17c919ea260ddeb6330effc4bbed8b30d11ed7b27e78d9d7af0445
DIST flit-3.3.0.tar.gz 117809 BLAKE2B 8ad74f70406e41b35b44886b145b52d83fc30d0a1395bf711807da2ae3974ae8606113e4bcd556694854c48c8c01c3c03b4a1021c7cc3e33cce0e99a5abbb9ea SHA512 904889298aab581640e8323fd68c83d753ea97af0ed1b8f438f192d84d09ced83718440a03d23864885fcf966de9665c3046f0f3a1b1d4170b2decf8430ff006
+DIST flit-3.4.0.tar.gz 120418 BLAKE2B e99eb67daa9a1d8e738ff9b917117edaf7372bbe267163f8af64967e43c3bed94893849e9752d36d3965e70c798dd3fb3b454131cee2d34697cc389f11aaea69 SHA512 18f1d1cb86508e76b4e37e6c1ca2c414400c86e9163bcc52fd3358220e5b4362da4001da7ce427926c62ad67ee86799ea8d08e858e5e17230941c529b9995ce5
diff --git a/dev-python/flit/flit-3.4.0.ebuild b/dev-python/flit/flit-3.4.0.ebuild
new file mode 100644
index 000000000000..1bc9a7f33b5c
--- /dev/null
+++ b/dev-python/flit/flit-3.4.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Simplified packaging of Python modules"
+HOMEPAGE="https://github.com/takluyver/flit https://flit.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ >=dev-python/flit_core-3.2.0[${PYTHON_USEDEP}]
+ dev-python/intreehooks[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests_download[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ dev-python/tomli-w[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ sys-apps/grep
+ sys-apps/findutils
+ test? (
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/flit-3.2.0-tests.patch"
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc \
+ dev-python/sphinxcontrib-github-alt \
+ dev-python/pygments-github-lexers \