summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2019-07-12 20:01:17 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-18 09:55:18 +0200
commit83a8eec53ee7f73199220b809b11bf47d907ecb4 (patch)
treee627e93bab57dfab13072e0fe45cd515a884933f /dev-python/flask-paginate
parentapp-editors/nano: add support for /usr merge (diff)
downloadgentoo-83a8eec53ee7f73199220b809b11bf47d907ecb4.tar.gz
gentoo-83a8eec53ee7f73199220b809b11bf47d907ecb4.tar.bz2
gentoo-83a8eec53ee7f73199220b809b11bf47d907ecb4.zip
dev-python/flask-paginate: verbump to 0.5.3
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: David Roman <davidroman96@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/12434 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-paginate')
-rw-r--r--dev-python/flask-paginate/Manifest1
-rw-r--r--dev-python/flask-paginate/flask-paginate-0.5.3.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/flask-paginate/Manifest b/dev-python/flask-paginate/Manifest
index 9b6d59f4d81a..8c83ac16dc4e 100644
--- a/dev-python/flask-paginate/Manifest
+++ b/dev-python/flask-paginate/Manifest
@@ -1,2 +1,3 @@
DIST flask-paginate-0.5.1.tar.gz 5397 BLAKE2B 819740f6d1ff55331932dfb1a588fb0a92b2a6ffbf66c0ffcedddb2014c42c10f76ce50306fb9e389c66fdeba98fbf0d476915e935530bfeecc853ec25c1f9d4 SHA512 f17610cc3861d587e1940a69957a9266459270453d8f7c15ae6b6e5fa91633194e01384b1cec98647db70f38090d18fd44bf2fc4cbbd8d1d64cf541a5bd620c2
DIST flask-paginate-0.5.2.tar.gz 5535 BLAKE2B c343fdbd04097ccbf187f7a0aa127157fd18e39e68c6ca6dfee0e30a31f6e6b25bac4f2d64cf7a88b4c9addb53e45f381146f9710d84335ceb684198ad164372 SHA512 03cdce455f64da226a64137c3a69fda23749280e52df5d4fc4850e816c38810519a2f5a79bdd06709fc686ff413bcbc4a1bf20da44eba7678c5f3e542c277037
+DIST flask-paginate-0.5.3.tar.gz 118570 BLAKE2B 0c6d1163dcd8144afa80b217ab3a714a39f4015aa732b4c32cf0feee0d7ee06968bd8549651f2941be9c60d3fd36a18e132dd4c174eb4148e63f83e461cbf519 SHA512 fe3cdc808459528c449611b2411c377d46bdef4995cd2851730e90dc0091da15479022f401e31113c4d39f766841d9701f285c81e0ec6293eddd4c8f0821567e
diff --git a/dev-python/flask-paginate/flask-paginate-0.5.3.ebuild b/dev-python/flask-paginate/flask-paginate-0.5.3.ebuild
new file mode 100644
index 000000000000..3bdd94ff9304
--- /dev/null
+++ b/dev-python/flask-paginate/flask-paginate-0.5.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+MY_COMMIT="510ad833106134711868653fb597bf75ea8ac34f"
+
+DESCRIPTION="Pagination support for flask"
+HOMEPAGE="https://flask-paginate.readthedocs.io"
+SRC_URI="https://github.com/lixxu/flask-paginate/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+python_test() {
+ pytest -vv tests/tests.py || die "tests failed with ${EPYTHON}"
+}