summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/flask-mongoengine
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/flask-mongoengine')
-rw-r--r--dev-python/flask-mongoengine/Manifest2
-rw-r--r--dev-python/flask-mongoengine/flask-mongoengine-0.7.0.ebuild32
-rw-r--r--dev-python/flask-mongoengine/flask-mongoengine-0.7.1.ebuild41
-rw-r--r--dev-python/flask-mongoengine/metadata.xml8
4 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/flask-mongoengine/Manifest b/dev-python/flask-mongoengine/Manifest
new file mode 100644
index 000000000000..6cf7d424d288
--- /dev/null
+++ b/dev-python/flask-mongoengine/Manifest
@@ -0,0 +1,2 @@
+DIST flask-mongoengine-0.7.0.tar.gz 103676 SHA256 e5031d1f812181699b10fec76d7c9c6633f19f8b686dcee48371e9216884f2b4 SHA512 3a9ce923b5d391e4fbdacc87d32e6cd8e0ada592c9fce585cf6dc38b8c116966cd70c83c2f2b77f580348722351c129ef38d7788f9ae2bd27d043de0d5487493 WHIRLPOOL 20583285ec18871b750c045a1dc911d6c836b152a27816b81805f12808dd68450236139245fd6ea07c9239544a7a62dafd358feaf13304910b6c6301f5f32567
+DIST flask-mongoengine-0.7.1.tar.gz 103947 SHA256 8ab895611a92b1e16f8467ddda0d4e8addee0ccf478f61d161ff58417caa06f2 SHA512 5da5c0a9794a108c2ff3adc3a6a415216841f060db54483b96421769879e7961c1137b787ad2ebd0ceb80a2187e4c7eaaecca4cb57c517e43aaf4845ac618c99 WHIRLPOOL afb4cf0a02678d1f4cfaa9c6d35d6086cf2e1f49a4b739348463173175f5928c7bacb2eecd3257bb0782021a5276761c187377ca3f2ec80560cdd086a86aa5c9
diff --git a/dev-python/flask-mongoengine/flask-mongoengine-0.7.0.ebuild b/dev-python/flask-mongoengine/flask-mongoengine-0.7.0.ebuild
new file mode 100644
index 000000000000..4d55ca66db93
--- /dev/null
+++ b/dev-python/flask-mongoengine/flask-mongoengine-0.7.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+RESTRICT="test" # broken
+
+DESCRIPTION="Flask support for MongoDB and with WTF model forms"
+HOMEPAGE="https://pypi.python.org/pypi/flask-mongoengine/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/mongoengine[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+ "
+
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}
diff --git a/dev-python/flask-mongoengine/flask-mongoengine-0.7.1.ebuild b/dev-python/flask-mongoengine/flask-mongoengine-0.7.1.ebuild
new file mode 100644
index 000000000000..c4c0b97eb079
--- /dev/null
+++ b/dev-python/flask-mongoengine/flask-mongoengine-0.7.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+RESTRICT="test" # broken
+
+DESCRIPTION="Flask support for MongoDB and with WTF model forms"
+HOMEPAGE="https://pypi.python.org/pypi/flask-mongoengine/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/flask-0.8[${PYTHON_USEDEP}]
+ >=dev-python/mongoengine-0.7.10[${PYTHON_USEDEP}]
+ dev-python/flask-wtf[${PYTHON_USEDEP}]
+ "
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/flask-mongoengine/metadata.xml b/dev-python/flask-mongoengine/metadata.xml
new file mode 100644
index 000000000000..866f98192a34
--- /dev/null
+++ b/dev-python/flask-mongoengine/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">flask-mongoengine</remote-id>
+ </upstream>
+</pkgmetadata>