summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-31 08:14:42 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-31 08:18:46 +0200
commitfae5b2c71aab36bbd9e5bfbdcd0534f4d4b21cff (patch)
tree38b09e4c5ab3cbc8306932b608868454a897a09b /dev-python/elementpath
parentdev-python/django-cache-url: Bump to 3.4.2 (diff)
downloadgentoo-fae5b2c71aab36bbd9e5bfbdcd0534f4d4b21cff.tar.gz
gentoo-fae5b2c71aab36bbd9e5bfbdcd0534f4d4b21cff.tar.bz2
gentoo-fae5b2c71aab36bbd9e5bfbdcd0534f4d4b21cff.zip
dev-python/elementpath: Bump to 2.5.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/elementpath')
-rw-r--r--dev-python/elementpath/Manifest1
-rw-r--r--dev-python/elementpath/elementpath-2.5.3.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/elementpath/Manifest b/dev-python/elementpath/Manifest
index 525103861af3..3ddbaa3ec26a 100644
--- a/dev-python/elementpath/Manifest
+++ b/dev-python/elementpath/Manifest
@@ -1,3 +1,4 @@
DIST elementpath-2.5.0.gh.tar.gz 263680 BLAKE2B 50ecea0766ddad4239b9283b223e945ae12fabf51bc246bb672517d04912b07cc2d46c1f04ff74f7f6da44d7dc422cde0c38a1f25a1f61068390dbfcc5ad58c4 SHA512 bbc6ce6a6a3eb3312d53be6040b8f4676f460e76de9b476410a3170734410b7a3d61c53081633d39089def05c74446d26abe093f02b9686a595cdb6e10440047
DIST elementpath-2.5.1.gh.tar.gz 263727 BLAKE2B adfc3727c8afe691ba09e143249779ca3f0cee2fd743963b013d790215b30650eecbe2c924a026c07f9018a23710a0ade6e83567103d8eeffd85a71d398b7c77 SHA512 35c272a9f3dc2ddb1ab6b1aaa67588c1e3fcc5765a2edfd4dae47346b7b45f209b38a501a24f0c37b5ca0d933928c13b8608f33a2aadc57e1e4eeb928a491ab8
DIST elementpath-2.5.2.gh.tar.gz 264230 BLAKE2B 03aa2da16eb503c5ad04f9f7af89d0b042d1bc9f22c66480cae4a0014d210f0d40ebfd564e3a224f5fb475996feb8ccd533fa1eda99c9be04ed063ffe6f0dca7 SHA512 c425ae4166b0a31f8473efc1cdc2b3f768f9e7881a5e974f995e8b39433bccd6603cbc4f78bd428fe5551c823bf357a38379b72cade3cf96b380d42da1684544
+DIST elementpath-2.5.3.gh.tar.gz 264387 BLAKE2B a0904e95675570783f2f8bf854490a3f424d6ce0fa85e3c2030483e9c31af4a5eaaf727db6423e17a402f55e7d42b0625a5183b543f886ec8b12426eb0e57a57 SHA512 da561446ac3a059c60480084648ebc1190d0ec1dc495dfa128dc2598d5762ae1067f39be36fc6bca466e6785aae80edf6dc1415a2885bfbb2d54b97ca6611572
diff --git a/dev-python/elementpath/elementpath-2.5.3.ebuild b/dev-python/elementpath/elementpath-2.5.3.ebuild
new file mode 100644
index 000000000000..44481bdc806a
--- /dev/null
+++ b/dev-python/elementpath/elementpath-2.5.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="XPath 1.0/2.0 parsers and selectors for ElementTree and lxml"
+HOMEPAGE="
+ https://github.com/sissaschool/elementpath/
+ https://pypi.org/project/elementpath/
+"
+SRC_URI="
+ https://github.com/sissaschool/elementpath/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # fails for some reason, more fit for upstream testing anyway
+ rm tests/test_typing.py || die
+ distutils-r1_src_prepare
+}