summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-13 05:25:52 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-13 05:25:52 +0100
commitd907814ec5c246e4bde719d703d448992a5752d3 (patch)
tree4c570d9700772c687c0a44c0c1f9f2647fcab393 /dev-python/editorconfig
parentdev-python/editorconfig-core-py: Prepare for rename (diff)
downloadgentoo-d907814ec5c246e4bde719d703d448992a5752d3.tar.gz
gentoo-d907814ec5c246e4bde719d703d448992a5752d3.tar.bz2
gentoo-d907814ec5c246e4bde719d703d448992a5752d3.zip
Move dev-python/{editorconfig-core-py → editorconfig}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/editorconfig')
-rw-r--r--dev-python/editorconfig/Manifest2
-rw-r--r--dev-python/editorconfig/editorconfig-0.12.3-r1.ebuild53
-rw-r--r--dev-python/editorconfig/metadata.xml24
3 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/editorconfig/Manifest b/dev-python/editorconfig/Manifest
new file mode 100644
index 000000000000..163c02aae408
--- /dev/null
+++ b/dev-python/editorconfig/Manifest
@@ -0,0 +1,2 @@
+DIST editorconfig-core-py-0.12.3.tar.gz 19261 BLAKE2B 58cac122cfee19527bc45def7e923da50982de0e2cd443cf67dd824c050fb12352b85a5679815a701bc5b8d88a089a0a98280c364730086d01b80f119ad996a4 SHA512 005d0698c410c8865d177a1e891b5c51b15255f36303b116fddbbbc08e309d1d60ca3003d27e6fd8455e53c5956db0c29e298f22f4b10950e1f7c56c7c6e0ab3
+DIST editorconfig-core-test-abb579e00f2deeede91cb485e53512efab9c6474.tar.gz 7900 BLAKE2B 9ebdb5e522948bc9e86ea84435ccaa11585a8a12f4cd6fe54c64d78917281c913568351767d8077623b1196d84206d1c2d0126a0510f70df484c1b55d829028b SHA512 ae5424b4926d6cb127cb3da473400ced4f7ccf224f7baa8bc5bde0317cc045bb7b99738a56efe5fd0e5a0fbe39b997b9fb1739d24713e7f83b58e987c5e56a32
diff --git a/dev-python/editorconfig/editorconfig-0.12.3-r1.ebuild b/dev-python/editorconfig/editorconfig-0.12.3-r1.ebuild
new file mode 100644
index 000000000000..df3872e19dc0
--- /dev/null
+++ b/dev-python/editorconfig/editorconfig-0.12.3-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{10..11} )
+inherit cmake distutils-r1
+
+MY_P=editorconfig-core-py-${PV}
+TESTVER="abb579e00f2deeede91cb485e53512efab9c6474"
+DESCRIPTION="Clone of EditorConfig core written in Python"
+HOMEPAGE="https://editorconfig.org/"
+SRC_URI="
+ https://github.com/editorconfig/editorconfig-core-py/archive/v${PV}.tar.gz
+ -> ${MY_P}.tar.gz
+ test? (
+ https://github.com/editorconfig/editorconfig-core-test/archive/${TESTVER}.tar.gz
+ -> editorconfig-core-test-${TESTVER}.tar.gz
+ )
+"
+
+LICENSE="PYTHON BSD-4"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cli test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !<app-vim/editorconfig-vim-0.3.3-r1
+ cli? ( !app-text/editorconfig-core-c[cli] )
+"
+
+src_prepare() {
+ if use test; then
+ mv "${WORKDIR}"/editorconfig-core-test-${TESTVER}/* "${S}"/tests || die
+ fi
+ if ! use cli; then
+ sed -i -e '/editorconfig\.__main__/d' setup.py || die
+ fi
+
+ cmake_src_prepare
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local mycmakeargs=(
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ )
+
+ cmake_src_configure
+ cmake_src_compile
+ cmake_src_test
+}
diff --git a/dev-python/editorconfig/metadata.xml b/dev-python/editorconfig/metadata.xml
new file mode 100644
index 000000000000..70597073fdfd
--- /dev/null
+++ b/dev-python/editorconfig/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <use>
+ <flag name="cli">Install command line interface as well as python library</flag>
+ </use>
+ <longdescription lang="en">
+ EditorConfig Python Core provides the same functionality as the
+ EditorConfig C Core. EditorConfig Python core can be used as a
+ command line program or as an importable library.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">editorconfig/editorconfig-core-test</remote-id>
+ <remote-id type="pypi">EditorConfig</remote-id>
+ </upstream>
+</pkgmetadata>