summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gentoo.org>2018-10-08 10:20:28 -0600
committerNicolas Bock <nicolasbock@gentoo.org>2018-10-08 10:20:48 -0600
commit51e34ac7d52360ff3718c23f0cc77add32395d49 (patch)
treea565e671b2e25d2ae070fc8df25f54b440aae875 /dev-python/ebuildtester/ebuildtester-0.1.14.ebuild
parentapp-text/html2text: EAPI7 revbump, improve ebuild (diff)
downloadgentoo-51e34ac7d52360ff3718c23f0cc77add32395d49.tar.gz
gentoo-51e34ac7d52360ff3718c23f0cc77add32395d49.tar.bz2
gentoo-51e34ac7d52360ff3718c23f0cc77add32395d49.zip
dev-python/ebuildtester: Version bump to 0.1.14
Package-Manager: Portage-2.3.49, Repoman-2.3.11 Signed-off-by: Nicolas Bock <nicolasbock@gentoo.org>
Diffstat (limited to 'dev-python/ebuildtester/ebuildtester-0.1.14.ebuild')
-rw-r--r--dev-python/ebuildtester/ebuildtester-0.1.14.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/ebuildtester/ebuildtester-0.1.14.ebuild b/dev-python/ebuildtester/ebuildtester-0.1.14.ebuild
new file mode 100644
index 000000000000..2cb7371a4528
--- /dev/null
+++ b/dev-python/ebuildtester/ebuildtester-0.1.14.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5,6} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="A dockerized approach to test a Gentoo package within a clean stage3 container"
+HOMEPAGE="http://ebuildtester.readthedocs.io/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ app-emulation/docker
+"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+src_install() {
+ distutils-r1_src_install
+ newbashcomp "${FILESDIR}/${PN}.bash-completion" "${PN}"
+}