summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-18 23:03:19 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-18 23:44:27 +0100
commitcd48e16a05b5b1d09fa22338e943423b1c4be184 (patch)
tree983fea174dc731203a3d5515c93002ea3a7ee39f /dev-python/dnspython
parentdev-python/frozenlist: Bump to 1.3.0 (diff)
downloadgentoo-cd48e16a05b5b1d09fa22338e943423b1c4be184.tar.gz
gentoo-cd48e16a05b5b1d09fa22338e943423b1c4be184.tar.bz2
gentoo-cd48e16a05b5b1d09fa22338e943423b1c4be184.zip
dev-python/dnspython: Bump to 2.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dnspython')
-rw-r--r--dev-python/dnspython/Manifest1
-rw-r--r--dev-python/dnspython/dnspython-2.2.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/dnspython/Manifest b/dev-python/dnspython/Manifest
index 9091c40204d1..1ef82ce4e79a 100644
--- a/dev-python/dnspython/Manifest
+++ b/dev-python/dnspython/Manifest
@@ -1,2 +1,3 @@
DIST dnspython-1.16.0.tar.gz 167172 BLAKE2B a246684aae8651d94b4312a4b4cce2236a0c4f2289a8fe8a2bb8e81c6beddf6e81a7d54928bc50f950fde862b27e589e83fa9f7aaff7d263a6442f47fe9bb3bb SHA512 825a1815855e036ea1dfece6ec0d42242f83163960439ecba3da58d9adb85b65dda7e628cf38c386807a6c0c36aa026d5e95f7a1bdc2927aa2f6f042f873c14c
DIST dnspython-2.1.0.tar.gz 279625 BLAKE2B ac90f1c9b50a00924326437e08513df04f3cf6dddee8b5ce58e628beab625d00c2dcdcc89e4b4da2c0366e650a5d8e87eb010942303215d3095e35f2010d4928 SHA512 eb3ab812eb8769b4780055b801e4f89beb1cb3d3e5a4855e583dca83b794eb7fca8fc3ef401eea7c16c34452e801dec5a2c59304f4041a68c7214dea6076435a
+DIST dnspython-2.2.0.tar.gz 303844 BLAKE2B 5a99a06d1c7e8f29e44ddc99fed11d772d83d962d7abde61befb3189c6faa2796b239e9c0ec05a453360986ff4bbbcea929f62017eb3bab2bafa517ae4c02a3b SHA512 0a93bde1ca1081c92b9fb5a02644c4920813f2d0dbe4de1dae736262d53afe41327f3fdd38a10f74ec78f54dd7c7570e37d0adb2b21ab18f9b5cc099fcc6bb85
diff --git a/dev-python/dnspython/dnspython-2.2.0.ebuild b/dev-python/dnspython/dnspython-2.2.0.ebuild
new file mode 100644
index 000000000000..483c1c5cc3dc
--- /dev/null
+++ b/dev-python/dnspython/dnspython-2.2.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="DNS toolkit for Python"
+HOMEPAGE="https://www.dnspython.org/
+ https://pypi.org/project/dnspython/"
+SRC_URI="https://github.com/rthalley/dnspython/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ <dev-python/idna-4.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/network_avail/s:True:False:' \
+ tests/*.py || die
+ distutils-r1_src_prepare
+
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}
+
+python_test() {
+ epytest -s
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}