summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-14 20:50:09 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-14 20:50:09 +0100
commit2576227bd2e0642dd4f2d3570b2c85b84c3b2aee (patch)
treedd46a814260f82be3d8bcb59a935aba7f84059fa /dev-python/django-cors-headers
parentdev-python/mkdocstrings: Bump to 0.24.0 (diff)
downloadgentoo-2576227bd2e0642dd4f2d3570b2c85b84c3b2aee.tar.gz
gentoo-2576227bd2e0642dd4f2d3570b2c85b84c3b2aee.tar.bz2
gentoo-2576227bd2e0642dd4f2d3570b2c85b84c3b2aee.zip
dev-python/django-cors-headers: Bump to 4.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-cors-headers')
-rw-r--r--dev-python/django-cors-headers/Manifest1
-rw-r--r--dev-python/django-cors-headers/django-cors-headers-4.3.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/django-cors-headers/Manifest b/dev-python/django-cors-headers/Manifest
index 9c15678971d6..72c6c3776c75 100644
--- a/dev-python/django-cors-headers/Manifest
+++ b/dev-python/django-cors-headers/Manifest
@@ -1,2 +1,3 @@
DIST django-cors-headers-4.2.0.gh.tar.gz 30543 BLAKE2B d17ec23b4579a84c67ec4edb369dda24db9bc64e2b399436e60f610b64b7de4b2a3583d9aa9e2693ebfd89f9d28c25def116b36f76bd4e2c3362ae36b50bb7ac SHA512 e3b0c73a738f487bc360834395b1bd6348c9d0a05fb743464ff0e5915f3d2263dbcabeaa893aa3d4be246504623964fb9378a780b83aa2487a92b2ada4a11c04
DIST django-cors-headers-4.3.0.gh.tar.gz 30571 BLAKE2B 9d1b07b26badc6357b526440fcbfe56be291d572ba3df4236a0963b6e05eabcb18d7719420c625d2d388fc630c27db3dc5eb3324e735a1600748ce7cf936d394 SHA512 5bc29154276833a0432863c5f96289595003fc47735aa2af4fa4154e239acb15366fa98cdcc9276ec9089c0d4d878466706bd2d65d5b55fb302ab4b4a93be683
+DIST django-cors-headers-4.3.1.gh.tar.gz 30478 BLAKE2B b07b08df239350fa1f2036130e434c1e543122c5a8867887819e5632a40e28c8ea3b18db87ad447b54c6b6ad87904504edf2bcb7de8bf619247d6ab9f703102d SHA512 cfabc3631774337fcb634e36e43af23dfd3e3c0316ff6e367b07a05d7f96dff77e3c0d0a5539f916e9169132b44944bbb79ba92705e36f54284cc1c9eb3c30d8
diff --git a/dev-python/django-cors-headers/django-cors-headers-4.3.1.ebuild b/dev-python/django-cors-headers/django-cors-headers-4.3.1.ebuild
new file mode 100644
index 000000000000..c7f8d2fb4df3
--- /dev/null
+++ b/dev-python/django-cors-headers/django-cors-headers-4.3.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Django App that adds CORS (Cross-Origin Resource Sharing) headers to responses"
+HOMEPAGE="
+ https://github.com/adamchainz/django-cors-headers/
+ https://pypi.org/project/django-cors-headers/
+"
+SRC_URI="
+ https://github.com/adamchainz/django-cors-headers/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/asgiref-3.6[${PYTHON_USEDEP}]
+ >=dev-python/django-3.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest