summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/discogs-client
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/discogs-client')
-rw-r--r--dev-python/discogs-client/Manifest2
-rw-r--r--dev-python/discogs-client/discogs-client-2.0.2.ebuild30
-rw-r--r--dev-python/discogs-client/discogs-client-2.2.0.ebuild33
-rw-r--r--dev-python/discogs-client/files/README.patch25
-rw-r--r--dev-python/discogs-client/metadata.xml13
5 files changed, 103 insertions, 0 deletions
diff --git a/dev-python/discogs-client/Manifest b/dev-python/discogs-client/Manifest
new file mode 100644
index 000000000000..130842346f2c
--- /dev/null
+++ b/dev-python/discogs-client/Manifest
@@ -0,0 +1,2 @@
+DIST discogs-client-2.0.2.tar.gz 25486 SHA256 7de2166ee4f7f5dc4cf1709b7a6abe6211a0046f2341874d2c67e5c6466351a8 SHA512 00634eb95018ccb2ece0adf4b7e3ea96674f0c8dd63d9bd151cdf9c871898fa24379f78065ebb677cc87eaffa31e91ba60051622a38c6bd774e010c20229b16e WHIRLPOOL ae54cdbb93d7fdfb26301f57a4ee3f0ec925a55a29c377c875221d62a0c54e54d957075ab04800fcc39aa3152317511ec775a66e6a5e25300558437c730faed5
+DIST discogs-client-2.2.0.tar.gz 27484 SHA256 b31e3fd8f17f46b9c7221182ed6be96774a334ac8be4e434ee99943d27170945 SHA512 e1f894cabab6c8162f0195164cd68fca7806149112d065c007991a4fb93de6bd4baa16230eaccde1e1d9d842930f6bb8ba64bd618352bc85051f64d3e7b13c0b WHIRLPOOL c903dc0348eddbd5c097972313cd04e7c9714f89ef8baac129b20ca01269b5be070f850f1d78b733bf408fb11ba40d26cae6b945bfb33bbdba16f8f9d5509a92
diff --git a/dev-python/discogs-client/discogs-client-2.0.2.ebuild b/dev-python/discogs-client/discogs-client-2.0.2.ebuild
new file mode 100644
index 000000000000..e092deb40965
--- /dev/null
+++ b/dev-python/discogs-client/discogs-client-2.0.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+# Not py3 capable due to oauth2 supports py2 pypy only
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Official Python API client for Discogs"
+HOMEPAGE="http://github.com/discogs/discogs_client http://pypi.python.org/pypi/discogs-client"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/discogs/${PN/-/_}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/oauth2[${PYTHON_USEDEP}]"
+# It's either this or make a test use flag to add RDEPEND behind it. Both work
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}"/${P/-/_}
+
+python_test() {
+ "${PYTHON}" -m unittest discover || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/discogs-client/discogs-client-2.2.0.ebuild b/dev-python/discogs-client/discogs-client-2.2.0.ebuild
new file mode 100644
index 000000000000..83536e3e32f5
--- /dev/null
+++ b/dev-python/discogs-client/discogs-client-2.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+# Not py3 capable due to oauth2 supports py2 pypy only
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Official Python API client for Discogs"
+HOMEPAGE="http://github.com/discogs/discogs_client http://pypi.python.org/pypi/discogs-client"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/discogs/${PN/-/_}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/oauth2[${PYTHON_USEDEP}]
+ dev-python/oauthlib[${PYTHON_USEDEP}]
+ "
+# It's either this or make a test use flag to add RDEPEND behind it. Both work
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}"/${P/-/_}
+
+python_test() {
+ "${PYTHON}" -m unittest discover || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/discogs-client/files/README.patch b/dev-python/discogs-client/files/README.patch
new file mode 100644
index 000000000000..538e96aa5f2e
--- /dev/null
+++ b/dev-python/discogs-client/files/README.patch
@@ -0,0 +1,25 @@
+From 7e914f37a851da1b7b52eb2bcb631f6148e41ee9 Mon Sep 17 00:00:00 2001
+From: Theofilos Intzoglou <int.teo@gmail.com>
+Date: Tue, 11 Jun 2013 21:24:35 +0300
+Subject: [PATCH] Fix README.mkd so that test_discogs_client.py doesn't fail
+
+---
+ README.mkd | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/README.mkd b/README.mkd
+index 73a609a..07f9724 100644
+--- a/README.mkd
++++ b/README.mkd
+@@ -185,7 +185,7 @@ Get a list of `Label`s representing sublabels associated with this `Label`:
+ Get the `Label`'s parent label, if it exists:
+
+ >>> label.parent_label
+- ...
++ <Label "...">
+
+ ### Possible `data` keys
+
+--
+1.8.1.6
+
diff --git a/dev-python/discogs-client/metadata.xml b/dev-python/discogs-client/metadata.xml
new file mode 100644
index 000000000000..b3d1da6cc08a
--- /dev/null
+++ b/dev-python/discogs-client/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>int.teo@gmail.com</email>
+ <name>Theofilos Intzoglou</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">discogs-client</remote-id>
+ <remote-id type="github">discogs/discogs_client</remote-id>
+ </upstream>
+</pkgmetadata>