summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-01-13 19:31:20 +0100
committerPacho Ramos <pacho@gentoo.org>2021-01-13 19:31:20 +0100
commit7f364ef6f0db94164d4a229c7853db7fcfbebb2b (patch)
tree0a3cad377c699ffa7605fb870a30a825cdebd600 /dev-python/defcon
parentdev-python/piexif: Mark ALLARCHES (diff)
downloadgentoo-7f364ef6f0db94164d4a229c7853db7fcfbebb2b.tar.gz
gentoo-7f364ef6f0db94164d4a229c7853db7fcfbebb2b.tar.bz2
gentoo-7f364ef6f0db94164d4a229c7853db7fcfbebb2b.zip
dev-python/defcon: Bump to 0.7.2
Closes: https://bugs.gentoo.org/759622 Thanks-to: Alessandro Barbieri Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-python/defcon')
-rw-r--r--dev-python/defcon/Manifest1
-rw-r--r--dev-python/defcon/defcon-0.7.2.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/defcon/Manifest b/dev-python/defcon/Manifest
index b40722009cdb..63004c6aac5f 100644
--- a/dev-python/defcon/Manifest
+++ b/dev-python/defcon/Manifest
@@ -1 +1,2 @@
DIST defcon-0.6.0.tar.gz 403682 BLAKE2B c85cf4f846cab3f7543dcec885221e9f828cdf56fb1a373c9d06b27a29c1ab22fc9702d2ce561af97e3d4aa3b03712538ce0b29a0042fa4a0fea6f11eacba69b SHA512 b981c87d2355dc83b5da0ea4879707336ade8ea4d6ca2bc13da064367938579f2a60dfa5b1c0fd3629f4a2de97676e4f02f30f99a6116049cc2a10abd13a3d7b
+DIST defcon-0.7.2.tar.gz 424146 BLAKE2B 6a3cc6c4bd8ccf030cda5fdaa3d7d2ba8aabc74daf71ce9a006de015d459ff0e5d876d584e7873fba7349a2941490db8d0ebd9a9c880e80db534b231639d3147 SHA512 9cf402b6626b75222e351d11afcde3e0c8be88b3ceb6ed4ff68cc3762b636905b61f31ece288f4d7e5273b6cd2b044661188a39fde1941e1bb5b483b23f3b42e
diff --git a/dev-python/defcon/defcon-0.7.2.ebuild b/dev-python/defcon/defcon-0.7.2.ebuild
new file mode 100644
index 000000000000..6a2042c9e578
--- /dev/null
+++ b/dev-python/defcon/defcon-0.7.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..8} )
+inherit distutils-r1
+
+DESCRIPTION="A set of UFO based objects for use in font editing applications"
+HOMEPAGE="https://github.com/robotools/defcon"
+SRC_URI="https://github.com/robotools/defcon/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/fonttools-3.31.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/fs[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest