summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-31 08:30:10 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-31 08:55:08 +0200
commit06a999bbaee24d3efe1a455edb861efcd2bd29ef (patch)
tree040058236dc2b32de70431350b92e6eb17756f8d /dev-python/deepmerge
parentdev-python/pyquery: Bump to 2.0.1 (diff)
downloadgentoo-06a999bbaee24d3efe1a455edb861efcd2bd29ef.tar.gz
gentoo-06a999bbaee24d3efe1a455edb861efcd2bd29ef.tar.bz2
gentoo-06a999bbaee24d3efe1a455edb861efcd2bd29ef.zip
dev-python/deepmerge: Bump to 2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/deepmerge')
-rw-r--r--dev-python/deepmerge/Manifest1
-rw-r--r--dev-python/deepmerge/deepmerge-2.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/deepmerge/Manifest b/dev-python/deepmerge/Manifest
index 2cccb5f1ce08..4b67774e9aba 100644
--- a/dev-python/deepmerge/Manifest
+++ b/dev-python/deepmerge/Manifest
@@ -1 +1,2 @@
DIST deepmerge-1.1.1.gh.tar.gz 15605 BLAKE2B ef6fbd30185a2990c72d6de0950275dd6f9f3e61c0c9c969fd69dab2123025d016ade98d42f09b30328b3cb5659b29b2d07836db4657acde97d9a2cc40c07039 SHA512 8ba4a225d588c96c3c852783774d5d690c5dd0caa1988f5969ce6446a11ba6035667baeda7e419cae40c4c1dcf7a15ee7149a10c1e33dba6b7775ddbad41130d
+DIST deepmerge-2.0.gh.tar.gz 16810 BLAKE2B bfc2803f0a955d83bf8e1fee380066475bf61962e640272b00e4df899ccdb62c7796e7717b761ee5f8f4659c53a048fcb6f519eaec0b5f54a03ade8991e783d1 SHA512 9580220d941226b7d5b27f8efe2f7caeea58da6d3aa48f2a20f54add75fb1f2802b17e16794f5e05f28c3943cf34ccbcb622c2073533201c5c66a4c44d0e4547
diff --git a/dev-python/deepmerge/deepmerge-2.0.ebuild b/dev-python/deepmerge/deepmerge-2.0.ebuild
new file mode 100644
index 000000000000..a6fd6b3bc8e3
--- /dev/null
+++ b/dev-python/deepmerge/deepmerge-2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tools to handle merging of nested data structures in python"
+HOMEPAGE="
+ https://deepmerge.readthedocs.io/en/latest/
+ https://github.com/toumorokoshi/deepmerge/
+ https://pypi.org/project/deepmerge/
+"
+SRC_URI="
+ https://github.com/toumorokoshi/deepmerge/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}