summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-12 17:21:19 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-12 17:48:04 +0200
commitb7b85a6f4a2922273a1b696e10dfb537a773370f (patch)
tree0a67ead2ddbe878e05351174da5e255a25ad47ae /dev-python/coverage
parentdev-python/zipp: Bump to 3.8.1 (diff)
downloadgentoo-b7b85a6f4a2922273a1b696e10dfb537a773370f.tar.gz
gentoo-b7b85a6f4a2922273a1b696e10dfb537a773370f.tar.bz2
gentoo-b7b85a6f4a2922273a1b696e10dfb537a773370f.zip
dev-python/coverage: Bump to 6.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/coverage')
-rw-r--r--dev-python/coverage/Manifest1
-rw-r--r--dev-python/coverage/coverage-6.4.2.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/coverage/Manifest b/dev-python/coverage/Manifest
index 94d0ad573f04..d97892925516 100644
--- a/dev-python/coverage/Manifest
+++ b/dev-python/coverage/Manifest
@@ -1 +1,2 @@
DIST coverage-6.4.1.tar.gz 719971 BLAKE2B 047c57ffae092a9e04470a64d090ee7c3274c5ab60dd69d67c8151e85954b5cf2c34748f2e2641ac8229ed66a238e994d93b17f7ac4c92bce3eb919a5b7f1795 SHA512 d7b40bae4fee36c71befb490ee3341b023c0bff38ed2c97cf57a65e47be44b71685b130879640b1c8560359dbc31b0da523f5c363f3544ff666b804c7af122f0
+DIST coverage-6.4.2.tar.gz 721847 BLAKE2B d4a36a4a8e6f70654be0b9f6c0a660419d31087ed6e05208e60f2919b6d46c1cff39c0d9db7aabb214d212b3b7ed325a862e2471735bf411b7b81f6d50debe79 SHA512 10254089ee51d09928831b01b5b6f30a9077ed0ee08594312dab5a3804be1539533d9cec7381dc2a4332471681d75a5b0cd6e3dec6d67e47906b7ae820b8aed3
diff --git a/dev-python/coverage/coverage-6.4.2.ebuild b/dev-python/coverage/coverage-6.4.2.ebuild
new file mode 100644
index 000000000000..8a27c2c95f30
--- /dev/null
+++ b/dev-python/coverage/coverage-6.4.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Code coverage measurement for Python"
+HOMEPAGE="
+ https://coverage.readthedocs.io/en/latest/
+ https://github.com/nedbat/coveragepy/
+ https://pypi.org/project/coverage/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ >=dev-python/unittest-mixins-1.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/^addopts/s:-q -n auto::' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+test_tracer() {
+ local -x COVERAGE_TEST_TRACER=${1}
+ einfo " Testing with the ${COVERAGE_TEST_TRACER} tracer ..."
+ epytest tests
+}
+
+python_test() {
+ "${EPYTHON}" igor.py zip_mods || die
+
+ local -x COVERAGE_TESTING=True
+ # TODO: figure out why they can't be imported inside test env
+ local -x COVERAGE_NO_CONTRACTS=1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=_hypothesis_pytestplugin,flaky.flaky_pytest_plugin,xdist.plugin
+
+ local prev_opt=$(shopt -p nullglob)
+ shopt -s nullglob
+ local c_ext=( "${BUILD_DIR}/install$(python_get_sitedir)"/coverage/*.so )
+ ${prev_opt}
+
+ if [[ -n ${c_ext} ]]; then
+ cp "${c_ext}" \
+ coverage/ || die
+ test_tracer c
+ rm coverage/*.so || die
+ else
+ test_tracer py
+ fi
+}