summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-18 08:28:21 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-18 09:07:01 +0100
commitfc9d41dbb7417da48afb8f193f9643c1238534bc (patch)
tree0302d2a062e022023726ddcf5c0529ad511ff191 /dev-python/cmd2
parentdev-python/pytest-regressions: Bump to 2.6.0 (diff)
downloadgentoo-fc9d41dbb7417da48afb8f193f9643c1238534bc.tar.gz
gentoo-fc9d41dbb7417da48afb8f193f9643c1238534bc.tar.bz2
gentoo-fc9d41dbb7417da48afb8f193f9643c1238534bc.zip
dev-python/cmd2: Bump to 2.5.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cmd2')
-rw-r--r--dev-python/cmd2/Manifest1
-rw-r--r--dev-python/cmd2/cmd2-2.5.8.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/cmd2/Manifest b/dev-python/cmd2/Manifest
index 41ccaff6e457..8eaac05aa0c9 100644
--- a/dev-python/cmd2/Manifest
+++ b/dev-python/cmd2/Manifest
@@ -1 +1,2 @@
DIST cmd2-2.5.7.tar.gz 691584 BLAKE2B a43f22817cd028913d1ec49150d826e33ddde1037c2cd1bce066d9ee85c20e5f59daa1b7d5365968aa7f17e3709bd7a58e586c449415ea93f62b157df08eb366 SHA512 b230b7fbad97bdba28a1335839e13c711ef629b0c18c1773c24c64a34626217659e1c362e8d72d71726baa06c50ba3f89732860eee8e527d1485de17e0eeacb7
+DIST cmd2-2.5.8.tar.gz 592395 BLAKE2B 52ea8ffd83dc8fdc904bba8b0bc72960d3782d0bf43a7dcb99b00d68f5bc4fcb5d17ddbe44655cb812bceed861a0dfd8d8753d818233dd9b1ad0e4461ce29eff SHA512 ce19006dff46279f14ac7d23ab4177b7926b061565ceff054291a508773ed0c037bdd20ffc72ecc99d44bcbc3751a486a14dd9d1d43c2e61a7ebd45cf967f06c
diff --git a/dev-python/cmd2/cmd2-2.5.8.ebuild b/dev-python/cmd2/cmd2-2.5.8.ebuild
new file mode 100644
index 000000000000..820c48bb0ffa
--- /dev/null
+++ b/dev-python/cmd2/cmd2-2.5.8.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 virtualx pypi
+
+DESCRIPTION="Extra features for standard library's cmd module"
+HOMEPAGE="
+ https://github.com/python-cmd2/cmd2/
+ https://pypi.org/project/cmd2/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pyperclip[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+# pyperclip uses clipboard backends in the following preference order:
+# pygtk, xclip, xsel, klipper, qtpy, pyqt5, pyqt4.
+# klipper is known to be broken in Xvfb, and therefore causes test
+# failures. to avoid them, we must ensure that one of the backends
+# preferred to it is available (i.e. xclip or xsel).
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ || (
+ x11-misc/xclip
+ x11-misc/xsel
+ )
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ # tests rely on very specific text wrapping...
+ local -x COLUMNS=80
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # TODO: tests_isolated?
+ epytest -o addopts= -p pytest_mock tests || die
+}