summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-13 18:52:19 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-13 19:09:22 +0200
commit7c549e2fe319b8457386d01cae697ea480399199 (patch)
tree5f6e5ae61719664f88142227de127ca10d066856 /dev-python/cli_helpers
parentapp-admin/vault: drop 1.10.6, 1.11.3 (diff)
downloadgentoo-7c549e2fe319b8457386d01cae697ea480399199.tar.gz
gentoo-7c549e2fe319b8457386d01cae697ea480399199.tar.bz2
gentoo-7c549e2fe319b8457386d01cae697ea480399199.zip
dev-python/cli_helpers: Bump to 2.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cli_helpers')
-rw-r--r--dev-python/cli_helpers/Manifest1
-rw-r--r--dev-python/cli_helpers/cli_helpers-2.3.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/cli_helpers/Manifest b/dev-python/cli_helpers/Manifest
index ab8aa22985b7..e513e0c73eea 100644
--- a/dev-python/cli_helpers/Manifest
+++ b/dev-python/cli_helpers/Manifest
@@ -1 +1,2 @@
DIST cli_helpers-2.2.1.tar.gz 34199 BLAKE2B 5fb5217321d92cd6c774337bdf444ad2a6120accfe32da08642a880a60f1bdb4c71f12657bd17c30f7b3f212216fad027ac9c786367563e01d58c54c15bf67b5 SHA512 4b4a8c3ab61ceeaa1986e5d9943b10351ff1b3339294a78ed740bff3bd555cace723e637d6627e26b832370583989aa2b0782f57949af2c1d504f93caceda2d8
+DIST cli_helpers-2.3.0.gh.tar.gz 34374 BLAKE2B 83978ee17aec8a02173460cf5d5c42751d4745c63a1f83c8fafdd55fcfb31e04d02a61f90db4a4fe8ba2049167306b06e1389db15230558a646589e3834745de SHA512 ee5f2adbca54c62c2f40be4c7b418760d12f331737a65bafdb8209989fc866f35d6c2ea1b9b0a12add6ed3fa576a84a2c8f62a2f3babf58706660f7d7eb8eb57
diff --git a/dev-python/cli_helpers/cli_helpers-2.3.0.ebuild b/dev-python/cli_helpers/cli_helpers-2.3.0.ebuild
new file mode 100644
index 000000000000..f9592c921866
--- /dev/null
+++ b/dev-python/cli_helpers/cli_helpers-2.3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python helpers for common CLI tasks"
+HOMEPAGE="
+ https://cli-helpers.rtfd.io/
+ https://github.com/dbcli/cli_helpers/
+ https://pypi.org/project/cli-helpers/
+"
+SRC_URI="
+ https://github.com/dbcli/cli_helpers/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/configobj-5.0.5[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest