summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-01-10 05:36:52 +0100
committerMichał Górny <mgorny@gentoo.org>2025-01-10 06:30:53 +0100
commit24872844397eebd2a7f69e90aa0471bee3f14185 (patch)
tree1d01a49625e6e68ff62e9e81510f9690a0622029 /dev-python/cfn-lint
parentdev-python/hypothesis: Bump to 6.123.13 (diff)
downloadgentoo-24872844397eebd2a7f69e90aa0471bee3f14185.tar.gz
gentoo-24872844397eebd2a7f69e90aa0471bee3f14185.tar.bz2
gentoo-24872844397eebd2a7f69e90aa0471bee3f14185.zip
dev-python/cfn-lint: Bump to 1.22.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cfn-lint')
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-1.22.4.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index 9d7f5369842c..889b545eed10 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -1,3 +1,4 @@
DIST cfn_lint-1.21.0.tar.gz 2747268 BLAKE2B 580fffc95d5829374f1dda111e2cc805639a463514112cabe0e34b6f53344991819f81b8246adb9fe3ee8fe59ee5db9000befead7a21ce85694bac248589a72a SHA512 2091f02a30ee22313db52094e9f54e5978eca69aa0c0cc96e1e39cae720f04165b4ff2aa0f01419c5327f149d5bd5ab16c4ba9b2af0a8f42b1a1872991a6e4da
DIST cfn_lint-1.22.2.tar.gz 2848845 BLAKE2B 4f9194e019c1dae1d373b8432693be9463a668e5db522c7a23adcfaf04c591e49d0d1dc4853323f32fdb0d2c8db1c9e7a0bf6cddf652541bb057cfc3525ed53e SHA512 8e80892692e4458591f9863ad43af8bd8c5fbe2e554c75dda3029ac73a5a04987238221d50a3d2597dc0195dd049f36f9fcdc2b917c68b9a4d6807b4e8bf411c
DIST cfn_lint-1.22.3.tar.gz 2700564 BLAKE2B d1bfed3fda2d5133919396a54257ad484c3c7fd50b1a387e94eff404f9b8175135f0f39455bc45b69c8112e2f2c57eb055d7b2c879415bdc4abfdad74b7bb34f SHA512 45502d913488784ff8e355a24317cce42fc7df39b3afd80b8fc170c9c5b7e6191f3ff41a460e8bb0277d1c21483aef8addb41d60fe2e8e5d13058aa85fefcc84
+DIST cfn_lint-1.22.4.tar.gz 2707627 BLAKE2B 348dbbc46e1e7be9041ccd64e3f9a6409e7276533c275e2329b94c5dc63ba13a49955c1912447326cd79eba2ea1c4eb8941a4552de25d493b2594ef8d4910333 SHA512 01c2a581fd02ecc553dd1e95741eda174a7290aeabbe91a8f0da96bd77276aa134c627b78f60a7c18085252d16fa8a1fc0067faad78e59c623924a3bcaa0166a
diff --git a/dev-python/cfn-lint/cfn-lint-1.22.4.ebuild b/dev-python/cfn-lint/cfn-lint-1.22.4.ebuild
new file mode 100644
index 000000000000..11b35b918d51
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-1.22.4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.94.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema-to-python-1.2.3[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ <dev-python/networkx-4[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/regex-2021.7.1[${PYTHON_USEDEP}]
+ >=dev-python/sarif-om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+ # TODO: it looks as if AWS_DEFAULT_REGION didn't work
+ test/unit/module/core/test_run_cli.py::TestCli::test_bad_config
+ test/unit/module/core/test_run_cli.py::TestCli::test_override_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_positional_template_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_template_config
+ # different graphviz version?
+ test/unit/module/template/test_template.py::TestTemplate::test_build_graph
+ )
+
+ # from tox.ini
+ local -x AWS_DEFAULT_REGION=us-east-1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}