summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-01-24 07:08:42 +0100
committerMichał Górny <mgorny@gentoo.org>2025-01-24 08:16:33 +0100
commit1ef9b70d89f813cdf4e728e35d336a9a2d390719 (patch)
tree3610b74294f390431b996cdcab7e51a185cc58fc /dev-python/cfn-lint
parentdev-python/uv: Bump to 0.5.24 (diff)
downloadgentoo-1ef9b70d89f813cdf4e728e35d336a9a2d390719.tar.gz
gentoo-1ef9b70d89f813cdf4e728e35d336a9a2d390719.tar.bz2
gentoo-1ef9b70d89f813cdf4e728e35d336a9a2d390719.zip
dev-python/cfn-lint: Bump to 1.22.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cfn-lint')
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-1.22.7.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index 478af9769d31..d25faae6c0bb 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -1,3 +1,4 @@
DIST cfn_lint-1.22.3.tar.gz 2700564 BLAKE2B d1bfed3fda2d5133919396a54257ad484c3c7fd50b1a387e94eff404f9b8175135f0f39455bc45b69c8112e2f2c57eb055d7b2c879415bdc4abfdad74b7bb34f SHA512 45502d913488784ff8e355a24317cce42fc7df39b3afd80b8fc170c9c5b7e6191f3ff41a460e8bb0277d1c21483aef8addb41d60fe2e8e5d13058aa85fefcc84
DIST cfn_lint-1.22.5.tar.gz 2722622 BLAKE2B 147f1ec4543a2e54c6b6652b439ca4dd870aad44532a71bc75564bcb71e1aed0258b0387e3be57ef2c8059343cefaf2fef1af02b9442c37347987c018c9411ef SHA512 772430a958e53b90c529311a6f90602de7c2ced9d86840907a9c1e612f18db456c6678d2de43b3bee2e3498cc71b238e2ab8564238aef4467cc285c52ad3a6dd
DIST cfn_lint-1.22.6.tar.gz 2734354 BLAKE2B cda53c8500de713af87c2ad9a1306869c8305cc26389a3e01403d6df0e1a0d4c4014811135712bfa2af54f6333a25c5687c8d5b9c163f4798b394e29a4644622 SHA512 7fddd9ddde5eca7b68e838535ce8a0a0b4d50807467cecb3c51e78736a0c49f85a81608481b7f89b972222b08530b4f29ae8023bf5cdbd70bc79ec27782e9b11
+DIST cfn_lint-1.22.7.tar.gz 2735518 BLAKE2B 4357981083d1a32c6be9194552ddb6d2064d8da59b869d617f0047833386232e7fbfede778ad5949a1a10708a1ea166c6bcdfecbaac0e4684e209c812fbde564 SHA512 c079f0b3f7947545ad79d8700833fca1ddc74bc9a224604ced3ab09981e6c363f73a6b214981fbdc16264611213d9a8a41e960de077943a4c407c79af458c551
diff --git a/dev-python/cfn-lint/cfn-lint-1.22.7.ebuild b/dev-python/cfn-lint/cfn-lint-1.22.7.ebuild
new file mode 100644
index 000000000000..11b35b918d51
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-1.22.7.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.94.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema-to-python-1.2.3[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ <dev-python/networkx-4[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/regex-2021.7.1[${PYTHON_USEDEP}]
+ >=dev-python/sarif-om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+ # TODO: it looks as if AWS_DEFAULT_REGION didn't work
+ test/unit/module/core/test_run_cli.py::TestCli::test_bad_config
+ test/unit/module/core/test_run_cli.py::TestCli::test_override_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_positional_template_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_template_config
+ # different graphviz version?
+ test/unit/module/template/test_template.py::TestTemplate::test_build_graph
+ )
+
+ # from tox.ini
+ local -x AWS_DEFAULT_REGION=us-east-1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}