summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-21 02:13:40 +0000
committerSam James <sam@gentoo.org>2021-12-21 02:14:41 +0000
commitee35be1dc88fca67d3845bf583d886912ca9bb73 (patch)
tree990c26ce1565ba97c6ed1970a0e15e9a10461bbd /dev-python/certifi
parentsys-fs/zfs: fix test build failure on musl in 2.1.2 (diff)
downloadgentoo-ee35be1dc88fca67d3845bf583d886912ca9bb73.tar.gz
gentoo-ee35be1dc88fca67d3845bf583d886912ca9bb73.tar.bz2
gentoo-ee35be1dc88fca67d3845bf583d886912ca9bb73.zip
dev-python/certifi: needs setuptools at runtime
Bug: https://github.com/tiran/certifi-system-store/pull/17 Closes: https://bugs.gentoo.org/822777 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/certifi')
-rw-r--r--dev-python/certifi/certifi-3021.3.16-r1.ebuild (renamed from dev-python/certifi/certifi-3021.3.16.ebuild)7
-rw-r--r--dev-python/certifi/files/certifi-3021.3.16-setuptools.patch21
2 files changed, 27 insertions, 1 deletions
diff --git a/dev-python/certifi/certifi-3021.3.16.ebuild b/dev-python/certifi/certifi-3021.3.16-r1.ebuild
index eedb8a3a3354..6019af2a84af 100644
--- a/dev-python/certifi/certifi-3021.3.16.ebuild
+++ b/dev-python/certifi/certifi-3021.3.16-r1.ebuild
@@ -5,6 +5,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{8..10} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
MY_P=certifi-system-store-${PV}
@@ -23,13 +24,17 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 s
RDEPEND="app-misc/ca-certificates"
-distutils_enable_tests --install pytest
+PATCHES=(
+ "${FILESDIR}"/${PN}-3021.3.16-setuptools.patch
+)
EPYTEST_IGNORE=(
# requires Internet
tests/test_requests.py
)
+distutils_enable_tests --install pytest
+
src_prepare() {
sed -i -e "s^/etc^${EPREFIX}/etc^" src/certifi/core.py || die
distutils-r1_src_prepare
diff --git a/dev-python/certifi/files/certifi-3021.3.16-setuptools.patch b/dev-python/certifi/files/certifi-3021.3.16-setuptools.patch
new file mode 100644
index 000000000000..57154fd0eed9
--- /dev/null
+++ b/dev-python/certifi/files/certifi-3021.3.16-setuptools.patch
@@ -0,0 +1,21 @@
+https://github.com/tiran/certifi-system-store/pull/17
+https://bugs.gentoo.org/822777
+
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Tue, 23 Nov 2021 15:56:33 +0100
+Subject: [PATCH] Add missing install_requires on setuptools
+
+This package is using pkg_resources explicitly, it should therefore
+declare an explicit dependency on setuptools. The missing dependency
+has lead me to actually miss the runtime dependency which caused issues
+for Gentoo users for whom setuptools were cleaned.
+--- a/setup.cfg
++++ b/setup.cfg
+@@ -40,6 +40,7 @@ zip_safe = True
+ setup_requires = setuptools
+ # hack to prevent installation on unsupported platforms Windows and macOS
+ install_requires =
++ setuptools
+ certifi-system-store > 4000; sys_platform == "win32" or sys_platform == "darwin"
+ python_requires = >=3.6
+