summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-01 01:57:55 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-01 02:29:35 +0100
commit9fca15ebc36b465e6d86694cf86b29bd3908ab83 (patch)
tree4d0efe5d751a1a93c86eee8427fe48ac2f3a748a /dev-python/cachelib
parentsys-devel/mold: use only one .sh on rm (diff)
downloadgentoo-9fca15ebc36b465e6d86694cf86b29bd3908ab83.tar.gz
gentoo-9fca15ebc36b465e6d86694cf86b29bd3908ab83.tar.bz2
gentoo-9fca15ebc36b465e6d86694cf86b29bd3908ab83.zip
dev-python/cachelib: Bump to 0.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cachelib')
-rw-r--r--dev-python/cachelib/Manifest1
-rw-r--r--dev-python/cachelib/cachelib-0.5.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/cachelib/Manifest b/dev-python/cachelib/Manifest
index 82013f93160d..77695239c4d0 100644
--- a/dev-python/cachelib/Manifest
+++ b/dev-python/cachelib/Manifest
@@ -1 +1,2 @@
DIST cachelib-0.4.1.tar.gz 19762 BLAKE2B baadfe920fda339cd8f3241664ae91b2767423ed09bdb6204573b2679e37c2dd3157f3b4d0f16841b1ab859f7c777986c0c251bcbe4bdf1ade69c442ff8ec756 SHA512 051e6f31b6ee58836a1512de4c7eedc718c081389df92605ad065f4bc5e4c861971507af636686d8abf00273a379ff31730bf040a7633a143dc1492263e3a543
+DIST cachelib-0.5.0.tar.gz 21173 BLAKE2B cbd6bb5e0be27dd284893ebd3e469821806c5d3634195b6cacc4ba247da9f8f3d33d0ad3043e80409f836907c24c1a8226dd0333a51488b86a7cd0244d66fe2b SHA512 1b942e654cf334755fe130a913504d6b46dbb1e6aef3df33cb295ded7e47b1ed461b68653d8bc8ffe85cff6fc82a382df82b97302ff191e184e953d837a02cdd
diff --git a/dev-python/cachelib/cachelib-0.5.0.ebuild b/dev-python/cachelib/cachelib-0.5.0.ebuild
new file mode 100644
index 000000000000..8c6fcd2d1980
--- /dev/null
+++ b/dev-python/cachelib/cachelib-0.5.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of cache libraries in the same API interface. Extracted from werkzeug"
+HOMEPAGE="https://pypi.org/project/cachelib/ https://github.com/pallets/cachelib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pylibmc[${PYTHON_USEDEP}]
+ dev-python/pytest-xprocess[${PYTHON_USEDEP}]
+ dev-python/redis-py[${PYTHON_USEDEP}]
+ net-misc/memcached
+ www-servers/uwsgi[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # bug #818523
+ tests/test_redis_cache.py
+)