summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-09 21:57:06 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-09 22:12:59 +0200
commitcee57769a1eed4219aa95d01bf19f749ab0a0a25 (patch)
tree8656ac2cf079b364b8f841bded5001ae51bf6131 /dev-python/build
parentdev-python/fakeredis: Remove versions without py3.8 (diff)
downloadgentoo-cee57769a1eed4219aa95d01bf19f749ab0a0a25.tar.gz
gentoo-cee57769a1eed4219aa95d01bf19f749ab0a0a25.tar.bz2
gentoo-cee57769a1eed4219aa95d01bf19f749ab0a0a25.zip
dev-python/build: Skip a test that requires dev-python/toml
Closes: https://bugs.gentoo.org/834567 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/build')
-rw-r--r--dev-python/build/build-0.7.0-r1.ebuild3
-rw-r--r--dev-python/build/build-0.8.0.ebuild3
2 files changed, 6 insertions, 0 deletions
diff --git a/dev-python/build/build-0.7.0-r1.ebuild b/dev-python/build/build-0.7.0-r1.ebuild
index 049661a8726c..6dbd928558f2 100644
--- a/dev-python/build/build-0.7.0-r1.ebuild
+++ b/dev-python/build/build-0.7.0-r1.ebuild
@@ -54,6 +54,9 @@ python_test() {
tests/test_main.py::test_build_package_via_sdist
'tests/test_util.py::test_wheel_metadata[True]'
tests/test_util.py::test_with_get_requires
+ # we don't really have to test that fallback
+ # (requires dev-python/toml that we'd like to lastrite eventually)
+ tests/test_projectbuilder.py::test_toml_instead_of_tomli
)
[[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
# fixed in git but the patch is large-ish
diff --git a/dev-python/build/build-0.8.0.ebuild b/dev-python/build/build-0.8.0.ebuild
index ca263e625e48..df040676ce48 100644
--- a/dev-python/build/build-0.8.0.ebuild
+++ b/dev-python/build/build-0.8.0.ebuild
@@ -58,6 +58,9 @@ python_test() {
tests/test_self_packaging.py::test_build_wheel
'tests/test_util.py::test_wheel_metadata[True]'
tests/test_util.py::test_with_get_requires
+ # we don't really have to test that fallback
+ # (requires dev-python/toml that we'd like to lastrite eventually)
+ tests/test_projectbuilder.py::test_toml_instead_of_tomli
)
epytest -p no:flaky -n "$(makeopts_jobs)" \