summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-10 06:17:40 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-10 06:17:40 +0200
commit2063a2d38b3f3601a97e2b72bc6319de2ab4f927 (patch)
treec74cef8906c4a1505a4f0aa0da2f6554532e7a6d /dev-python/build
parentdev-python/characteristic: Remove old (diff)
downloadgentoo-2063a2d38b3f3601a97e2b72bc6319de2ab4f927.tar.gz
gentoo-2063a2d38b3f3601a97e2b72bc6319de2ab4f927.tar.bz2
gentoo-2063a2d38b3f3601a97e2b72bc6319de2ab4f927.zip
dev-python/build: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/build')
-rw-r--r--dev-python/build/Manifest1
-rw-r--r--dev-python/build/build-0.7.0-r1.ebuild68
-rw-r--r--dev-python/build/build-0.7.0.ebuild55
3 files changed, 0 insertions, 124 deletions
diff --git a/dev-python/build/Manifest b/dev-python/build/Manifest
index 4c7f19a605b3..34a325b4b6e6 100644
--- a/dev-python/build/Manifest
+++ b/dev-python/build/Manifest
@@ -1,2 +1 @@
-DIST build-0.7.0.gh.tar.gz 37127 BLAKE2B b06ba16c154087046bd5efddb5fd6f60dad9ee79a204a0c1124fb4885d3692bcf4bd88b75c9665ade3f8457e12742d32e3cef40a0ffb5a894b049a6e942c09e3 SHA512 fd8410dc91333ba94c5141dd78f8052b66f947839752a5d0f401630f6bceed5be2e1f45eceaa2a98908c0e3ddb88a00e3ccca341a3890fa99202bc560ab6ff42
DIST build-0.8.0.gh.tar.gz 40020 BLAKE2B 17422c8fe23d4103c78bd9d98702646f0863abfea4ff5df425942eb71aa905d8171567976228681afa90f453131ccce4701128b4f73b61acf4158ea2758c5c9e SHA512 62eaabef36fae592b06c41623f8f36750a029263a65c8fa21ad58b24ef30d4fa8eef7588237a68efb9a9784676f35605a8c9a6b2ed1bc6844c32924f9b5ec377
diff --git a/dev-python/build/build-0.7.0-r1.ebuild b/dev-python/build/build-0.7.0-r1.ebuild
deleted file mode 100644
index 6dbd928558f2..000000000000
--- a/dev-python/build/build-0.7.0-r1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-
-inherit distutils-r1 multiprocessing
-
-DESCRIPTION="A simple, correct PEP517 package builder"
-HOMEPAGE="
- https://pypi.org/project/build/
- https://github.com/pypa/build/
-"
-SRC_URI="
- https://github.com/pypa/build/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-RDEPEND="
- >=dev-python/packaging-19.0[${PYTHON_USEDEP}]
- >=dev-python/pep517-0.9.1[${PYTHON_USEDEP}]
- >=dev-python/tomli-1.0.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- >=dev-python/filelock-3[${PYTHON_USEDEP}]
- >=dev-python/pytest-mock-2[${PYTHON_USEDEP}]
- >=dev-python/pytest-rerunfailures-9.1[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- >=dev-python/setuptools-56.0.0[${PYTHON_USEDEP}]
- >=dev-python/wheel-0.36.0[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # broken by the presence of flit_core
- tests/test_util.py::test_wheel_metadata_isolation
- # broken by the presence of virtualenv (it changes the error
- # messages, sic!)
- tests/test_env.py::test_isolated_env_log
- tests/test_main.py::test_output_env_subprocess_error
- 'tests/test_main.py::test_output[via-sdist-isolation]'
- 'tests/test_main.py::test_output[wheel-direct-isolation]'
- # Internet
- tests/test_main.py::test_build_package
- tests/test_main.py::test_build_package_via_sdist
- 'tests/test_util.py::test_wheel_metadata[True]'
- tests/test_util.py::test_with_get_requires
- # we don't really have to test that fallback
- # (requires dev-python/toml that we'd like to lastrite eventually)
- tests/test_projectbuilder.py::test_toml_instead_of_tomli
- )
- [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
- # fixed in git but the patch is large-ish
- tests/test_env.py::test_executable_missing_post_creation
- )
-
- epytest -p no:flaky -n "$(makeopts_jobs)" \
- -W"ignore:path is deprecated.:DeprecationWarning"
-}
diff --git a/dev-python/build/build-0.7.0.ebuild b/dev-python/build/build-0.7.0.ebuild
deleted file mode 100644
index 8555e5d4feb2..000000000000
--- a/dev-python/build/build-0.7.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1 multiprocessing
-
-DESCRIPTION="A simple, correct PEP517 package builder"
-HOMEPAGE="
- https://pypi.org/project/build/
- https://github.com/pypa/build/"
-SRC_URI="
- https://github.com/pypa/build/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/packaging-19.0[${PYTHON_USEDEP}]
- >=dev-python/pep517-0.9.1[${PYTHON_USEDEP}]
- >=dev-python/tomli-1.0.0[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- >=dev-python/filelock-3[${PYTHON_USEDEP}]
- >=dev-python/pytest-mock-2[${PYTHON_USEDEP}]
- >=dev-python/pytest-rerunfailures-9.1[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- >=dev-python/setuptools-56.0.0[${PYTHON_USEDEP}]
- >=dev-python/wheel-0.36.0[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # broken by the presence of flit_core
- tests/test_util.py::test_wheel_metadata_isolation
- # broken by the presence of virtualenv (it changes the error
- # messages, sic!)
- tests/test_env.py::test_isolated_env_log
- tests/test_main.py::test_output_env_subprocess_error
- 'tests/test_main.py::test_output[via-sdist-isolation]'
- 'tests/test_main.py::test_output[wheel-direct-isolation]'
- # Internet
- tests/test_main.py::test_build_package
- tests/test_main.py::test_build_package_via_sdist
- 'tests/test_util.py::test_wheel_metadata[True]'
- tests/test_util.py::test_with_get_requires
- )
-
- epytest -p no:flaky \
- -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
-}